Yahoo lambasted over using outdated Java with SiteBuilder

One security expert called Yahoo's distributing of vulnerability-ridden versions of Java to small businesses 'shockingly irresponsible'

Yahoo has come under severe criticism by security experts decrying its practice of steering small businesses to a Web site-building tool that uses an insecure 2008 version of Java.

Businesses signing up for Yahoo's Web hosting service are directed to SiteBuilder, a free Web-based tool for building basic sites for e-commerce. SiteBuilder provides a simple point-and-click development environment that requires Java.

[MORE JAVA: Oracle to release more patches for Java]

The security of sites built with the tool is compromised because Yahoo deploys the out-of-date Java 6 Update 7, KrebsonSecurity reported. Java steward Oracle recently released two new versions, Java 6 Update 39 and Java 7 Update 13.

"It is shockingly irresponsible to be distributing old versions of Java, let alone 4-year-old versions," said Chester Wisniewski, a senior security adviser for Sophos. "I am not sure how it could happen, other than Yahoo must have thought it was a good idea to host its own copy of Java for users of its SiteBuilder service."

Yahoo has yet to explain why it is leaving small businesses open to attack from hackers. The Web portal did not respond to multiple requests for comment.

Because of its age, the version of Java deployed with SiteBuilder contains hundreds of known vulnerabilities that have been patched over the years. The use of the older technology has security experts calling on Yahoo to make fixing the problem its highest priority.

[Also see: Oracle's Java security update lacking, say experts]

"Yahoo should immediately inform their users of the serious security problems their software has introduced to their systems and offer an estimate on when the fix will be available, as well as some interim mitigation advice," said Andrew Storms, director of security operations at nCircle. "In light of the potential harm their users are exposed to, this seems like the very least they can do."

Experts believe it is possible SiteBuilder requires an out-of-date copy of Java to operate. Storms points out that the help section advises users to install an older version of Java, advice he says is "just plain dangerous."

Wisniewski agrees that Yahoo's approach is unacceptable. "They should update their code to be compatible with the latest releases from Oracle," he said.

Cybercriminals target Java more than any other Web technology. That's because Oracle is slow in patching the platform used in running Java applications and because people often fail to keep the Java plug-in in Web browsers up-to-date.

Studies have shown that the majority of installations are outdated, leaving computers open to infection through drive-by downloads on compromised websites. 

This story, "Yahoo lambasted over using outdated Java with SiteBuilder" was originally published by CSO .

Editors' Picks
Join the discussion
Be the first to comment on this article. Our Commenting Policies