Ruby on Rails security update available

First off, what is it? Well, for those of you who may not know, Ruby on Rails is an open source web frame work that has been around since 2003. It was first developed by David Heinemeier Hansson and has since gone on to be used in thousands of web applications such as Basecamp, Twitter and Github.

Ruby on Rails has released their newest versions of their software. These iterations, versionRails 3.2.18, 4.0.5 and 4.1.1, are available for download from their website as of May 6, 2014. The reason for this update is a vulnerability that is found in CVE-2014-0130 which is a directory traversal vulnerability that affects all previous versions of Ruby on Rails.

From the advisory:

The implicit render functionality allows controllers to render a template, even if there is no explicit action with the corresponding name. A This module does not perform adequate input sanitization which could allow an attacker to use a specially crafted request to retrieve arbitrary files from the rails application server.A

In order to be vulnerable an application must specifically use globbing routes[1] in combination with the :action parameter. A The purpose of the route globbing feature is to allow parameters to contain characters which would otherwise be regarded as separators, for example '/' and '.'. A As these characters have semantic meaning within template filenames, it is highly unlikely that applications are deliberately combining these functions.A

To determine if you are vulnerable, search your application's routes files for '*action'

More reading on this is available on the National Vulnerability DatabaseA andA OSVDB.

You can download the latest version or Ruby on Rails here.

This story, "Ruby on Rails security update available" was originally published by CSO.

From CSO: 7 security mistakes people make with their mobile device
Join the discussion
Be the first to comment on this article. Our Commenting Policies