NetBeans IDE drops Ruby on Rails backing

Low usage and Java prioritization lead to the elimination of Rails backing, a move that did not come as a surprise to the Rails founder

Citing low usage trends and a priority on Java, builders of the NetBeans IDE have killed off Ruby on Rails support in a planned upgrade, the NetBeans community announced on Thursday.

In a posting on the NetBeans community site, the NetBeans Team reported the cessation, noting the Ruby on Rails module will be eliminated from development builds of the NetBeans 7.0 IDE, which is due this spring. "After thorough consideration, we have taken the difficult step to discontinue support for Ruby on Rails in the NetBeans IDE," the team said, noting that "although our Ruby support has historically been well-received, based on existing low usage trends, we are unable to justify the continued allocation of resources to support the feature."

[ In addition to Java SE 7 backing, NetBeans 7.0 also is set to feature faster deployments to the WebLogic Server application server as well as a JSON formatter. | Keep up with the latest in developer news with InfoWorld's Developer World newsletter. ]

A commitment to upcoming Java platforms also was cited in the post. "Java SE 7 and JDK 7 (Java Development Kit 7) are the next major releases of the Java SE platform, which Oracle is committed to deliver in 2011. A key objective of the NetBeans IDE has always been to offer superior support for the Java platform. To maintain that objective and capitalize on the JDK 7 release themes -- multi-language support, developer productivity, and performance -- it is necessary that our engineering resources are committed to a timely and quality release of NetBeans IDE 7.0. "

The founder of Ruby on Rails, David Heinemeier Hansson, said in an email that he was "not surprised" by the NetBeans move. "I never came across anyone using NetBeans for Rails. Everyone I talk to uses TextMate, VIM, or Emacs. Full-fledged IDEs are not all that popular in the Rails world," Hansson said.

Rails support has been in NetBeans since at least 2007. Developers who want to continue using Rails functionality with NetBeans are being referred to the NetBeans Ruby Support page. Rails can be used with NetBeans 6.9.1 or earlier versions of the IDE.

Begun as a Sun Microsystems project, NetBeans became an Oracle-sponsored endeavor when Oracle completed its acquisition of Sun a year ago.

This article, "NetBeans IDE drops Ruby on Rails backing," was originally published at InfoWorld.com. Follow the latest developments in business technology news and get a digest of the key stories each day in the InfoWorld Daily newsletter. For the latest developments in business technology news, follow InfoWorld.com on Twitter.

Read more about developer world in InfoWorld's Developer World Channel.

This story, "NetBeans IDE drops Ruby on Rails backing" was originally published by InfoWorld .

Join the discussion
Be the first to comment on this article. Our Commenting Policies