
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="no-js lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="no-js lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Unix: How random is random? | Network World</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html"/>
<meta itemprop="url" content="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html"/>
<meta name="description" content="On Unix systems, there are many ways to generate random numbers and many important roles that random data plays."/>
<meta name="news_keywords" content="random,pseudo-random,generate,numbers,urandom,/dev/urandom,shuf,EaaS"/>
<meta name="DC.date.issued" content="2017-07-17T08:01-05:00"/>
<meta name="date" content="2017-07-17"/>
<link rel="amphtml" href="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.amp.html"/>
<meta property="og:title" content="Unix: How random is random?">
<meta property="og:image" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg"/>
<link rel="image_src" href="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg"/>
<meta name="twitter:image" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Sandra Henry-Stocker">
<meta property="og:site_name" content="Network World"/>
<meta property="fb:app_id" content="147094931979429"/>
<meta property="og:url" content="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html">
<meta name="twitter:url" content="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html">
<!-- Add to article pages only -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@networkworld">
<meta property="og:description" content="On Unix systems, there are many ways to generate random numbers and many important roles that random data plays.">
<meta name="twitter:description" content="On Unix systems, there are many ways to generate random numbers and many important roles that random data plays.">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="google-site-verification" content="OnAuriQCKcyQ0EoVwZP5SB1dhrHOFhHpUzZ21n9viHM"/>
<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="linux,security,programmer,sandra-henry-stocker,unix-as-a-second-language,howto,medium"/>
<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg"/>
<meta name="displaytype" content="article"/>
<meta name="blogs" content="unix as a second language"/>
<meta name="source" content="network world"/>
<meta name="category" content="linux,security"/>
<meta name="storytype" content="howto"/>
<meta name="tags" content="programmers"/>
<!-- pagination -->
<style>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</style>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css?v=20170717114015"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css?v=20170717114015"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www.idge/css/article.css?v=20170717114015"/>
<link rel="stylesheet" href="/www.idge/css/print.css?v=20170717114015" media="print"/>
<link rel="stylesheet" href="/www.idge.nww/css/article.css?v=20170717114015"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css?v=20170717114015"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css?v=20170717114015"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<link href="http://fonts.googleapis.com/css?family=Source+Sans+Pro:400,700,400italic,700italic" rel="stylesheet" type="text/css"/>
<script type="text/javascript" src="http://fonts.staticworld.net/lbi2kpq.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="/www.idge.nww/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://idge.staticworld.net/nww/nww_logo_144x144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://idge.staticworld.net/nww/nww_logo_114x114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="http://idge.staticworld.net/nww/nww_logo_72x72.png"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="http://idge.staticworld.net/nww/nww_logo_57x57.png"/>
<link rel="apple-touch-icon" href="http://idge.staticworld.net/nww/nww_logo_300x300.png"/>
<!-- js -->
<script src="/www.idge/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js?v=20170717114015"></script>
<!-- google_dfp needs jquery defined first -->
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20170717114015"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script src="/www/js/ads/narf_prebid.js?v=20170717114015"></script>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js?v=20170717114015"></script>
<!-- End of LiveRamp -->
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_NetworkWorld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"linux_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article-blog/linux');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("blogId",'1247');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3208389');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'howto');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'4');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3353,2206]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['linux','security']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Sandra Henry-Stocker');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("blog_name",'Unix as a Second Language');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("tagNames",'Programmers');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript">console.log("PROXIMIC RESPONSE: PAGE-LEVEL");(function(){try{var proximic_data={"data":["300003","121100","112200","131100","131127","131132","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","e2co9k","20f4sh","folvaf","r03wnl","1nolfc","bkwp85","enwcef","44ywyv","bsuu95","xks7sj","x8eev1","7grvv1","agtqg7","agt9m3","9v0tiu","pcz604","n2qz3z","64l66x","500247"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20170717114015"></script>
<script type="text/javascript">$thm.useBusinessData=true;</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"2619":"07dd"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451478":"6353218"));}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script type="text/javascript" src="/www/js/ads/prebid_gpt_launcher.js?v=20170717114015"></script>
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="nww";var brandName="Network World";var regDebugLog=false;var regApiUrl=" http://regdev.idge.int/api/ ";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".networkworld.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="http://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js?v=20170717114015"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20170717114015"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<!-- All JavaScript at the bottom, except for Modernizr which enables HTML5 elements & feature detects -->
<script src="/www.idge/js/mule/modernizr.js?v=20170717114015"></script>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"blogpost",eloqua_topic:"operatingsystems"};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var g_arrModules=new Array();</script>
<meta name="parsely-title" content="Unix: How random is random?"/>
<meta name="parsely-link" content="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.3x2.jpg"/>
<meta name="parsely-pub-date" content="2017-07-17T15:01:00Z"/>
<meta name="parsely-section" content="Linux"/>
<meta name="parsely-author" content="Sandra Henry-Stocker"/>
<meta name="parsely-tags" content="Programmers,blog: Unix as a Second Language,type: howto,source: networkworld,imported"/>
<script src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script>dataLayer=[{'primaryCategory':'Linux','ga_enabled':'true','articleType':'How-To','articleId':'3208389','articleTitle':'Unix: How random is random?','blogName':'Unix as a Second Language','parselyEnabled':'true','parselyDomain':'networkworld.com','viglinksId':'4a111b041e558f2e9ee27fa7415b4915','sailthruCustomerId':'5fb8d6c0731a8bb2f3ec7f437fe7404e','geolocEnabled':'true'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3208389/linux/unix-how-random-is-random.html";_sf_async_config.title="Unix: How random is random? | Network World";_sf_async_config.domain="networkworld.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="linux";_sf_async_config.authors="Sandra Henry-Stocker";</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-P3S27S" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P3S27S');</script>
<!-- End Google Tag Manager -->
</head>
<body id="article3208389" class="article blog1247 network world">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<a href="javascript:unhide('superadunit');" id="superstitial-text">This ad will close in 20 seconds. Continue to site &raquo;</a>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
<!-- blx4 #809 blox4.raw_link_list  -->
<ul>
<li><a href="/article/3197415/security/how-to-maintain-data-oversight-to-avoid-shadow-data.html">How to avoid ‘shadow data’</a></li>
<li><a href="/article/3197575/software/tpus-googles-machine-learning-pipeline-explained.html">Google’s machine-learning cloud pipeline</a></li>
<li><a href="/article/3196984/application-development/the-emergence-of-devops-in-the-evolving-digital-enterprise.html">DevOps in the digital enterprise</a></li>
<li><a href="/article/3196856/cloud-computing/how-to-avoid-downtime-and-disruption-when-moving-data.html">Disruption when moving data</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
</ul>
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/networkworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/network-world" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="http://www.facebook.com/#!/pages/Network-World/40168412104" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+networkworld/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/about/rss.html" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">network world</span></a>
<!--
	            	<img class="print-only" src="/www.idge.nww/images/networkworld-logo-print.png">
	            	-->
<img class="print-only" src="http://idge.staticworld.net/nww/networkworld-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
<div class="insider-signin">
<span class="signin-register">
<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
</span>
<div id="welcome-message" class="insider-list">
<div id="insider-selector">
<div id="insider-welcome" class="label"></div>
<div class="stories">
<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
<ul>
<li><a href="/article/3203489/lan-wan/what-is-5g-gigabit-plus-wireless-to-enable-mobile-only-networking.html">What is 5G? Wireless tecnology that could enable mobile-only networking</a></li>
<li><a href="/article/3206305/lan-wan/does-mu-mimo-really-expand-wi-fi-system-capacity.html">Does MU-MIMO really expand Wi-Fi system capacity?</a></li>
<li><a href="/article/3203369/lan-wan/10-most-important-open-source-networking-projects.html">10 Most important open source networking projects </a></li>
<li><a href="/article/3053668/lan-wan/5-must-have-network-tools.html">7 must-have network tools </a></li>
</ul>
<div class="sign-out-link">
<a class="more-insider" href="/insider/">More Insider</a>
<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
</div>
</div>
</div>
</div>
</div>
<script>$('.signin-register').hide();$('#welcome-message').hide();</script>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/careers/" class="hasChildren">Careers<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/careers/">All Careers</a></li>
<li><a href="/category/education/">Education</a></li>
<li><a href="/category/salary/">Salaries</a></li>
<li><a href="/category/it-skills-training/">Skills and Training</a></li>
</ul>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/data-center/" class="hasChildren">Data Centers<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/data-center/">All Data Centers</a></li>
<li><a href="/category/business-continuity/">Business Continuity</a></li>
<li><a href="/category/green-it/">Green IT</a></li>
<li><a href="/category/network-storage/">Network Storage</a></li>
<li><a href="/category/computers/">PCs</a></li>
<li><a href="/category/servers/">Server Hardware</a></li>
<li><a href="/category/tablets/">Tablets</a></li>
<li><a href="/category/virtual-desktop/">Virtual Desktop</a></li>
</ul>
</li>
<li><a href="/category/disaster-recovery/">Disaster Recovery</a>
</li>
<li><a href="/category/home-tech/">Home Tech</a>
</li>
<li><a href="/category/hybrid-cloud/">Hybrid Cloud</a>
</li>
<li><a href="/category/internet-of-things/">Internet of Things</a>
</li>
<li><a href="/category/infrastructure/" class="hasChildren">Infrastructure Management<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/infrastructure/">All Infrastructure Management</a></li>
<li><a href="/category/application-performance-management/">Application Performance Management</a></li>
<li><a href="/category/asset-management/">Asset Management</a></li>
<li><a href="/category/network-management/">Network Management</a></li>
<li><a href="/category/system-management/">System Management</a></li>
</ul>
</li>
<li><a href="/category/linux/">Linux</a>
</li>
<li><a href="/category/mobile-wireless/" class="hasChildren">Mobile &amp; Wireless<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/mobile-wireless/">All Mobile &amp; Wireless</a></li>
<li><a href="/category/android/">Android</a></li>
<li><a href="/category/byod/">BYOD</a></li>
<li><a href="/category/cellular-networks/">Cellular Networks</a></li>
<li><a href="/category/mdm-mam/">MDM</a></li>
<li><a href="/category/mobile-apps/">Mobile Apps</a></li>
<li><a href="/category/smartphones/">Smartphones</a></li>
<li><a href="/category/ios/">iOS</a></li>
</ul>
</li>
<li><a href="/category/lan-wan/" class="hasChildren">Networking<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/lan-wan/">All Networking</a></li>
<li><a href="/category/internet/">Internet</a></li>
<li><a href="/category/router/">Routers</a></li>
<li><a href="/category/telecommunication/">Service Providers</a></li>
<li><a href="/category/wan-optimization/">WAN Optimization</a></li>
<li><a href="/category/wi-fi/">Wi-Fi</a></li>
</ul>
</li>
<li><a href="/category/software-defined-networking/">SDN</a>
</li>
<li><a href="/category/security/" class="hasChildren">Security<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/security/">All Security</a></li>
<li><a href="/category/application-security/">Application Security</a></li>
<li><a href="/category/compliance/">Compliance</a></li>
<li><a href="/category/malware-cybercrime/">Cyber Crime</a></li>
<li><a href="/category/endpoint-protection/">Endpoint Protection</a></li>
<li><a href="/category/mobile-security/">Mobile Security</a></li>
<li><a href="/category/network-security/">Network Security</a></li>
</ul>
</li>
<li><a href="/category/small-business/">Small Business</a>
</li>
<li><a href="/category/software/" class="hasChildren">Software<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/software/">All Software</a></li>
<li><a href="/category/big-data-business-intelligence/">Big Data</a></li>
<li><a href="/category/crm/">CRM</a></li>
<li><a href="/category/erp/">ERP</a></li>
<li><a href="/category/windows/">Windows</a></li>
</ul>
</li>
<li><a href="/category/storage/">Storage</a>
</li>
<li><a href="/category/uc-voip/" class="hasChildren">Unified Communications<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/uc-voip/">All Unified Communications</a></li>
<li><a href="/category/collaboration/">Collaboration</a></li>
<li><a href="/category/email/">Email</a></li>
<li><a href="/category/social-networking/">Social Networking</a></li>
<li><a href="/category/videoconferencing/">Videoconferencing</a></li>
<li><a href="/category/voip/">VoIP</a></li>
</ul>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
<li><a href="/category/wide-area-networking/">WAN</a>
</li>
<li><a href="/category/cisco-subnet/">Cisco Subnet</a>
</li>
<li><a href="/category/microsoft-subnet/">Microsoft Subnet</a>
</li>
<li><a href="/category/tech-primers/">Tech Primers</a>
</li>
</ul>
<ul class="secondary">
<li><a href="/news/">News</a></li>
<li><a href="/reviews/">Reviews</a></li>
<li><a href="/insider/">Insider</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="http://www.ereg.me/IDGEvents" target="_blank" rel="nofollow">Network World Events</a></li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>$(document).ready(function(){$('body').addClass('insider-plus');var headerHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main.no-stick').css("top",headerHeight);if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main').height();stickyHeaderHeight=stickyHeaderHeight-8;}var supportsOrientationChange="onorientationchange"in window,orientationEvent=supportsOrientationChange?"orientationchange":"resize";if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<170){top=0;}else{top=top-50;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$thm.deviceHeight()<768){if($('html').hasClass('touch')){$('#insider-popup.modal-box .modal-body').addClass('short');}else{$('#insider-popup.modal-box .modal-body').addClass('short-desk');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<50){top=5;}else{top=top-40;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}var ua=navigator.userAgent.toLowerCase();var isAndroid=ua.indexOf("android")>-1;window.addEventListener(orientationEvent,function(){if(isAndroid&&(screen.width==600||screen.width==960)){location.reload(true);}},false);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.desktop)&&!$('html').hasClass('touch')){$("ul.social li.more-social").mouseenter(function(){$('ul.social > li').addClass('display-icon');});$("ul.social").mouseleave(function(){$('ul.social > li').removeClass('display-icon');});};if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$('html').hasClass('touch')){$("ul.social li.more-social").click(function(){$('ul.social > li').toggleClass('display-icon');});};$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});function sticky_relocate(){var headerHeight=$('header#banner').height();var winHeight=$(window).height();if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight-40;if(window.orientation==90||window.orientation==-90){winHeight=winHeight+50;}}else if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight+40;}else{winHeight=winHeight+10;}$('#banner nav#sticky-nav.main').css("height",winHeight);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top;if(window_top>div_top){$('#sticky-head').addClass('stick');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');}else{$('#sticky-head').removeClass('stick');$('#page-wrapper').removeClass('top-pad');$('#banner .ad').removeClass('top-margin');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('section.topics').addClass('stick-topics');$('#sticky-head').addClass('stick-head');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');$('#banner section.tools-expand').addClass('search');var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top+30;if(window_top>div_top){$('#sticky-head').addClass('stick');$('.topics.stick-topics, #search-form').addClass('remove');$('li.search-icon').fadeOut("fast");}else{$('#sticky-head').removeClass('stick');$('.topics.stick-topics, #search-form').removeClass('remove');$('li.search-icon').fadeIn("fast");}}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){if($('#sticky-head').hasClass('stick')){var stickyHeaderHeight=$('section.main').height();stickyHeaderHeight=52;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');$('#sticky-nav').removeClass('no-stick');}else{stickyHeaderHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').removeClass('stick');$('#sticky-nav').addClass('no-stick');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main.stick-head').height();stickyHeaderHeight=stickyHeaderHeight-8;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');if($('#sticky-head').hasClass('stick')){$('#sticky-head.stick').siblings('#sticky-nav').addClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').removeClass('no-stick');}else{$('#sticky-head').siblings('#sticky-nav').removeClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').addClass('no-stick');}}}$(function(){$(window).scroll(sticky_relocate);sticky_relocate();});</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/BlogPosting" class="blog">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/linux/" itemprop="url"><span itemprop="title">Linux</span></a></li>
</ul>
</nav>
<div class="blog-byline vcard author with-image" itemscope itemtype="http://schema.org/Person" itemprop="author">
<div class="brand ">
<a href="/author/Sandra-Henry_Stocker/" rel="author" title="Sandra Henry-Stocker"><img class="bylineImage  imgId100646724 " src="http://core1.staticworld.net/images/article/2016/02/sandra_h-s-3-100646724-byline.jpg" width="34" width="34" alt="Sandra Henry-Stocker" itemprop="image"/></a>
<div class="blog-branding-text">
<div class="blog-title"><a href="/blog/unix-as-a-second-language/">Unix as a Second Language</a></div>
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
By <span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Sandra-Henry_Stocker/"><span itemprop="name">Sandra Henry-Stocker</span></a></span>,
<span class="cn-container">
</span>
Unix Dweeb,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Network World</span></span>
<span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2017-07-17T08:01-0700">Jul 17, 2017 8:01 AM
PT
</span>
</p>
</div>
</div>
</div>
<div class="category"></div>
<h1 itemprop="headline">Unix: How random is random?</h1>
<div class="cat-social">
<div id="sharer" class="cat sidecar show blog">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.networkworld.com%2Farticle%2F3208389%2Flinux%2Funix-how-random-is-random.html&via=networkworld&text=Unix%3A+How+random+is+random%3F" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.networkworld.com%2Farticle%2F3208389%2Flinux%2Funix-how-random-is-random.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.networkworld.com%2Farticle%2F3208389%2Flinux%2Funix-how-random-is-random.html&title=Unix%3A+How+random+is+random%3F" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.networkworld.com%2Farticle%2F3208389%2Flinux%2Funix-how-random-is-random.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.networkworld.com%2Farticle%2F3208389%2Flinux%2Funix-how-random-is-random.html&title=Unix%3A+How+random+is+random%3F" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.networkworld.com%2Farticle%2F3208389%2Flinux%2Funix-how-random-is-random.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){var eloquaParam={AssetCountforCurrentCampaign:"1",AssetName:"",AssetTopic:"",AssetType:"",BuyingCycle:"",C_Address1:"",C_Address2:"",C_BusPhone:"",C_City:"",C_Company_Size1:"",C_Country:"",C_EmailAddress:"",C_FirstName:"",C_Industry1:"",C_Job_Role1:"",C_LastName:"",C_State_Prov:"",C_Zip_Postal:"",ClientName:"",ProgramName:"",brand:"",elqFormName:"CentralRegistrationMasterForm",formId:"3062313",elqSiteId:1856,elqCustomerGUID:elqCustomerGUID,elqCookieWrite:0,friend_email:emailFrom,friend_article_title:"Unix: How random is random?",friend_taxo:"Linux",friend_source:"Network World",friend_article_url:"http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html",device_platform:navigator.userAgent};$.ajax("http://now.eloqua.com/e/f2.aspx",{type:'GET',data:eloquaParam,success:function(data,textStatus,xhr){},error:function(xhr,textStatus,errorThrown){}});var eloquaParamMini={elqCustomerGUID:elqCustomerGUID,friend_taxo:"Linux",friend_source:"Network World",device_platform:navigator.userAgent};formData+="&"+encodeQueryData(eloquaParamMini);$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=true&id=3208389">
<input type="hidden" name="title" value="Unix: How random is random?"/>
<input type="hidden" name="url" value="http://www.networkworld.com/article/3208389/linux/unix-how-random-is-random.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on Network World." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LdPbfsSAAAAAB89GpzHsyYe-AGzZXYy9K_4KAnF"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1">
<img src="https://images.idgesg.net/images/article/2017/07/random-vladimer_shioshvili-100729292-large.jpg" alt="Unix: How random is random?" itemprop="contentUrl"/>
<figcaption>
Credit:<span itemprop="copyrightHolder">
<a href="https://www.flickr.com/photos/vshioshvili/8313738660/in/photolist-dEE5RJ-miVHVZ-WtfPTq-VB4d7L-8jx4o4-VZKJNe-UUVy8N-VZKKwP-VuKY3X-9i4wAw-WJfULV-6f3poB-6rDocS-KGgUe-UotPkR-VetvXF-ajXNUL-dfa6ts-87Qv4W-b51ibF-WwBQGZ-dfa9ut-8Co5oU-cNGiDq-9Bp3km-2dyEn-WJgn9e-efMRqF-9rSAxv-Vyxapt-dfa7Ja-W8WKQ3-WJfZEn-6aujQ5-hua3-4fCstd-6bDbUb-8CcdnA-ck1Hky-6yNGLZ-6aqdtv-6aumjG-4BMw96-6aqeic-97g35h-6aq91P-3N3APN-WEFjLf-6aqeep-W8WXqN" target="_blank" rel="nofollow">Vladimer Shioshvili</a>
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">Related</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3194830/linux/10-unix-commands-every-mac-and-linux-user-should-know.html"><img class="small.3x2Image  imgId100498247 " src="http://core1.staticworld.net/images/idge/imported/imageapi/2014/10/08/15/slide_7unix-mug-100498247-small.3x2.jpg" alt="unix mug commands linux" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3194830/linux/10-unix-commands-every-mac-and-linux-user-should-know.html">10 Unix commands every Mac and Linux user should know</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3190910/application-development/tap-the-power-of-googles-go-language.html"><img class="small.3x2Image  imgId100690054 " src="http://core3.staticworld.net/images/article/2016/10/electrical_grid_powerline-100690054-small.3x2.jpg" alt="electrical grid powerline" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3190910/application-development/tap-the-power-of-googles-go-language.html">Tap the power of Google&#039;s Go language</a></div>
</div>
</li>
<li class="clearfix ">
<div class="item">
<div class="title"><a href="/article/2285422/lan-wan/emerging-linux-filesystems---part-2.html">Emerging Linux filesystems - Part 2</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/51206/solo-drone-has-linux-smarts-gopro-mount"><i class="ss-play"></i></a>
<a href="/video/51206/solo-drone-has-linux-smarts-gopro-mount"><img class="small.3x2Image  imgId100580405 " src="http://core0.staticworld.net/images/article/2015/04/selfie-100580405-small.3x2.jpg" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/51206/solo-drone-has-linux-smarts-gopro-mount">Solo drone has Linux smarts, GoPro mount</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>On Unix systems, random numbers are generated in a number of ways and random data can serve many purposes. From simple commands to fairly complex processes, the question “How random is random?” is worth asking.</p><h3>EZ random numbers</h3><p>If all you need is a casual list of random numbers, the RANDOM variable is an easy choice. Type "echo $RANDOM" and you'll get a number between 0 and 32,767 (the largest number that two bytes can hold).</p><pre>$ echo $RANDOM
29366
</pre><p>Of course, this process is actually providing a "pseudo-random" number. As anyone who thinks about random numbers very often might tell you, numbers generated by a program have a limitation. Programs follow carefully crafted steps, and those steps aren’t even close to being truly random. You can increase the randomness of RANDOM's value by seeding it (i.e., setting the variable to some initial value). Some just use the current process ID (via $$) for that. Note that for any particular starting point, the subsequent values that $RANDOM provides are quite predictable.</p><pre>$ RANDOM=$$;echo $RANDOM; echo $RANDOM;echo $RANDOM
7424
28301
30566
$ RANDOM=$$;echo $RANDOM; echo $RANDOM;echo $RANDOM
7424
28301
30566
</pre><p>If you need random numbers fairly frequently, maybe another seed would work better. Here we're using the number of seconds since the Unix epoch.</p><aside class="nativo-promo smartphone" id=""> </aside><pre>$ RANDOM=`date +%s`;echo $RANDOM;echo $RANDOM;echo $RANDOM
32077
1397
32029
$ RANDOM=`date +%s`;echo $RANDOM;echo $RANDOM;echo $RANDOM
16116
16487
11588
</pre><p>You can also use the <strong>shuf</strong> command to generate pseudo-random numbers. In the command below, we're generating 10 numbers between 0 and 32,767. The shuf command should start each sequence with a different number (no need for seeding).</p><pre>$ shuf -i 0-32767 -n 10
32157
16611
24087
28301
9088
4662
12780
30518
7549
12830
</pre><h3>More complex random data</h3><p>For more serious requirements for random data, such as its use in encryption, some more truly random data comes into play. The /dev/random and /dev/urandom files get beyond the predictability of programming by making use of environmental noise gathered from device drivers and other system sources and stored it in an “entropy pool”.</p><p>Pseudo-random number generation (often referred to as “PRNG”) on Unix systems makes use of these two files. From the command line, these files look like this:</p><pre>crw-rw-rw- 1 root root 1, 8 Jun 18 13:24 random
crw-rw-rw- 1 root root 1, 9 Jun 18 13:24 urandom
</pre><p>Like most, if not all, of the files in /dev, these files are both zero-length files and, like /dev/null, provide a special service that isn’t obvious by looking at a file listing. The /dev/random and /dev/urandom files can be used to generate numbers that at least approach approximate random values and random numbers are key to encrypting content in order to prevent it from being predictable.</p><aside class="nativo-promo tablet desktop" id=""> </aside><p>Using the stat command, you can get a more descriptive listing than ls provides for either of these files. Here’s the listing for /dev/urandom. Notice the zero length and the date stamps. This file was generated when the system last booted.</p><pre>$ stat /dev/urandom
  File: /dev/urandom
  Size: 0               Blocks: 0          IO Block: 4096   character special file
Device: 6h/6d   Inode: 1056        Links: 1     Device type: 1,9
Access: (0666/crw-rw-rw-)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2017-07-15 13:24:49.719736172 -0400
Modify: 2017-07-15 13:24:49.719736172 -0400
Change: 2017-07-15 13:24:49.719736172 -0400
 Birth: -
</pre><h3>Examining entropy</h3><p>To get an idea how much entropy is available on a system, you can look at the special file named “entropy_avail” – /proc/sys/kernel/random/entropy_avail to be more precise. Note that this file lives in the /proc file system—not a file system like those we generally work in, but a file system related to the kernel and running processes. The entropy_avail file will look like it’s empty, but displaying its contents tell you what you need to know.</p><pre>-r--r--r-- 1 root root 0 Jul 15 16:01 entropy_avail
</pre><p>To get a feel for how much pseudo-random data is available in your entropy pool, you can run this command:</p><pre>$ cat /proc/sys/kernel/random/entropy_avail
2684
</pre><p>The number shown appears to represent the number of bits of entropy that have been collected. Even 2,684 might not seem like much in a world in which we routinely speak in terms of terrabytes, but numbers above 100 are said to be a good sign. In addition, the number will change frequently. Check three times in a row, and you might see something like this.</p><pre>$ cat /proc/sys/kernel/random/entropy_avail
2683
$ cat /proc/sys/kernel/random/entropy_avail
2684
$ cat /proc/sys/kernel/random/entropy_avail
2493
</pre><p>The two files — /dev/random and /dev/urandom — consume the entropy pool and work nearly the same except for one important distinction — /dev/random will block when it runs out of entropy and might halt a process while /dev/urandom will never block, but might have less entropy. The /dev/urandom file appears to be the more reliable choice today.</p><h3>Randomness vs. entropy</h3><p>Now that the word “entropy” has entered the discussion, let’s consider the relationship of the words randomness and entropy. While tightly related, they don’t mean exactly the same thing. Entropy is reminiscent of a coin toss and is a measure of the uncertainty of an outcome, while randomness is related to a probabilistic distribution. For computer folk, the terms are often used as if they mean exactly the same thing.</p><h3>Generating files with random data</h3><p>You can create a file of pseudo-random data if you need one. In this command, we create a 1 gigabyte file called “myfile” and then examine the first line with an od command just to get a feel for what was created.</p><p>Creating the file:</p><pre>$ head -c 1G &lt; /dev/urandom &gt; myfile
</pre><p>Looking at the file:</p><pre>$ ls -l myfile
-rw-rw-r-- 1 shs shs 1073741824 Jul 14 15:10 myfile
$ head -1 myfile | od -bc
0000000 210 365 102 233 332 203 075 262 302 064 255 110 265 372 365 176
        210 365   B 233 332 203   = 262 302   4 255   H 265 372 365   ~
0000020 274 243 116 012
        274 243   N  \n
</pre><h3>Generating random numbers</h3><p>You can use /dev/urandom to generate pseudo-random numbers on the command line like this.</p><pre>$ od -vAn -N4 -tu &lt; /dev/urandom
 2760998497
</pre><p>Commands like this that pull data from /dev/urandom and use od to process it can generate nearly random numbers. Run the same command numerous times and you’ll see that you get a range of numbers.</p><pre>$ od -vAn -N4 -tu &lt; /dev/urandom
  184254494
$ od -vAn -N4 -tu &lt; /dev/urandom
 3081534763
</pre><p>Two of the options used with these of commands are particularly interesting. The -N controls the size of the output as the number in bytes. So, -N4 means the resultant number should be four bytes long. This doesn’t mean the resultant number provided can’t be a small number like 12—just that it will use four bytes. The largest numbers you will see will have ten digits. Switch to -N5 and you’ll get two numbers—one using 4 bytes and one using 1. Omit the -N option, and you’ll get a continuous stream of numbers—at least until you get tired of looking at them and hit ^C.</p><pre>$ od -vAn -N5 -tu &lt; /dev/urandom
  823515068        196
$ od -vAn -tu &lt; /dev/urandom
 2860283906 3419549082 3207848245 2737687912
 1333710913  933348251 2572772980 1418852288
 3788708580  870673152 4083922259 1506538622
 3772099425 3296232922  692742105  818767715
 3576300418 2497391372 3756319951 1357979412
 1588018330  740469378 3140770678  958473449
  187769983  168320294  393843609 3925659647
 1320592631 3858359323 1435946222 2841928818
   99971705 1732928020 2292358742 2367929537
</pre><p>Do this same thing with /dev/random and you’re likely to run out of steam fairly quickly.</p><pre>$ od -vAn -tu &lt; /dev/random
  897129786 2714319998 1496103441 4272099144
   99601145 3584433910 2759928205  817917225
 1692688250 3711124362  787695563 2107932582
  427417199 3136902189 1527656210 2881971698
 3895588188 1111869233 1024834659 3486503580
 4184363003 3255228299  634631930 2477891792
^Z
[1]+  Stopped                 od -vAn -tu &lt; /dev/random
</pre><p>Note that the ^Z was used to suspend the process when it hung on the command line. Also keep in mind that the entropy pool gets used up and regenerates.</p><h3>Beyond /dev/urandom</h3><p>Given the limitations of /dev/random and /dev/urandom, there are also some interesting options. There are now more than a dozen a hardware random number generators (also known as “true random number generators”, often referred to by the acronym “TRNG”) available today. In addition, “Entropy as a Service” (EaaS) is available as an option that could dramatically change the nature of randomness on systems close to you. More on this soon!</p><p>To get a quick introduction to EaaS, check out <a href="http://csrc.nist.gov/projects/eaas/" target="_blank">NIST’s introduction</a>—and stay tuned for some additional insights here on NetworkWorld.</p>
<div class="end-note">
<!-- blx4 #2005 blox4.html  -->
<div id="" class="blx blxParticleendnote blxM2005  blox4_html  blxC23909">Join the Network World communities on <a href="https://www.facebook.com/NetworkWorld/" target="_blank">Facebook</a> and <a href="https://www.linkedin.com/company/network-world" target="_blank">LinkedIn</a> to comment on topics that are top of mind.</div>
</div>
</div>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/linux">Linux</a></li>
<li><a href="/category/security">Security</a></li>
<li><a href="/tag/programmer/" rel="nofollow">Programmers</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio"><p>Sandra Henry-Stocker has been administering Unix systems for more than 30 years. She describes herself as "USL" (Unix as a second language) but remembers enough English to write books and buy groceries. She lives in the mountains in Virginia where, when not working with or writing about Unix, she's chasing the bears away from her bird feeders.</p></p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Sandra-Henry_Stocker/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="mailto:bugfarm@gmail.com">
<i class="ss-icon ss-mail"></i>
</a>
</li>
<li>
<a href="https://twitter.com/bugfarm" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="https://www.facebook.com/bugfarm" class="facebook-follow" target="_blank">
<i class="ss-icon ss-social ss-facebook"></i>
</a>
</li>
<li>
<a href="/author/Sandra-Henry_Stocker/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<!-- blx4 #1524 blox4.article.toaster  -->
<div class="article-intercept">
<a href="http://www.networkworld.com/article/3161905/windows/10-new-ui-features-coming-to-windows-10.html#tk.cross_2nww_intrcpt">
<i class="ss-icon ss-navigateright"></i><em> Must read:</em> 10 new UI features coming to Windows 10
</a>
</div>
<script src="/www/js/video/embedder.js?v=20170717114015"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_9b336e"></div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30206;if(is_blocked===true){widget_id=30281;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="http://trends.revcontent.com/serve.js.php?w=30206&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_9b336e");rcds.appendChild(rcel);});})();</script>
</div>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		
			
			
				$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
			
		
		if (Object.keys(IDG.GPT.companions).length > 0) {
		IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4355594142&iu=/8456/IDG.US_E_CIO.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
Cloud-based intelligence solutions optimize and engage. Here's why.
</a>
</li>
</ul><ul>
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=954574976&iu=/8456/IDG.US_E_NetworkWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
INSTANTLY dtSearch® TERABYTES OF FILE+EMAIL+DB+WEB DATA; reviews/evals
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.networkworld.com">
<a href="/"><span class="logo">Network World</span></a>
<span class="tagline"> </span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/networkworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/network-world" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="http://www.facebook.com/#!/pages/Network-World/40168412104" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+networkworld/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/about/rss.html" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li><a href="/category/careers/">Careers</a>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/data-center/">Data Centers</a>
</li>
<li><a href="/category/disaster-recovery/">Disaster Recovery</a>
</li>
<li><a href="/category/home-tech/">Home Tech</a>
</li>
<li><a href="/category/hybrid-cloud/">Hybrid Cloud</a>
</li>
<li><a href="/category/internet-of-things/">Internet of Things</a>
</li>
<li><a href="/category/infrastructure/">Infrastructure Management</a>
</li>
<li class="selected"><a href="/category/linux/" class="active">Linux</a>
</li>
<li><a href="/category/mobile-wireless/">Mobile &amp; Wireless</a>
</li>
<li><a href="/category/lan-wan/">Networking</a>
</li>
<li><a href="/category/software-defined-networking/">SDN</a>
</li>
<li><a href="/category/security/">Security</a>
</li>
<li><a href="/category/small-business/">Small Business</a>
</li>
<li><a href="/category/software/">Software</a>
</li>
<li><a href="/category/storage/">Storage</a>
</li>
<li><a href="/category/uc-voip/">Unified Communications</a>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
<li><a href="/category/wide-area-networking/">WAN</a>
</li>
<li><a href="/category/cisco-subnet/">Cisco Subnet</a>
</li>
<li><a href="/category/microsoft-subnet/">Microsoft Subnet</a>
</li>
<li><a href="/category/tech-primers/">Tech Primers</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
<li><a href="/feature">Features</a></li>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="http://www.ereg.me/IDGEvents" target="_blank" rel="nofollow">Network World Events</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/contactus.html">Contact</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="http://www.idgenterprise.com/reach/networkworld/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="http://careers.idg.com/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/sitemap.html">Site Map</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2017 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="http://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="http://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="http://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="http://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="http://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="http://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="http://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="http://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="http://www.idgknowledgehub.com" target="_blank" rel="nofollow">IDG Knowledge Hub</a></li>
<li><a href="http://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="http://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="http://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="http://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="http://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="http://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="http://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="http://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="http://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="http://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="http://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="http://www.pcworld.com" target="_blank" rel="nofollow">PC World</a></li>
<li><a href="http://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="http://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js?v=20170717114015"></script>
<script src="/www/js/jquery/jquery-ui.js?v=20170717114015"></script>
<script src="/www/js/jquery/jquery.dfp.min.js?v=20170717114015"></script>
<script src="/www.idge/js/mule/shortstack_nav.js?v=20170717114015"></script>
<script src="/www.idge/js/jquery/jt-scrollable.min.js?v=20170717114015"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js?v=20170717114015"></script>
<script src="/www/js/autocomplete.js?v=20170717114015"></script>
<script src="/www.idge/js/social_sidecar.js?v=20170717114015"></script>
<script src="/www/js/carousel-extend.js?v=20170717114015"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js?v=20170717114015"></script>
<script src="/www.idge/js/article.js?v=20170717114015"></script>
<script src="/www/js/prettify.js?v=20170717114015"></script>
<script src="/www.idge/js/jquery/responsive-tables.js?v=20170717114015"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js?v=20170717114015"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js?v=20170717114015"></script>
<script src="/www.idge/js/global.js?v=20170717114015"></script>
<script src="/www/js/webfonts/ss-social.js?v=20170717114015"></script>
<script src="/www/js/webfonts/ss-standard.js?v=20170717114015"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="http://tags.bkrtx.com/js/bk-coretag.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js?v=20170717114015"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14351;var blueKaiPort=10;var brandCode="nww";var regUrl="http://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="http://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[3353,2206]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','4');bk_addPageCtx("purchaseintent","notapplicable");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickLinux');bk_addPageCtx('event','AmazonClickSecurity');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js?v=20170717114015"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['']=true;g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;g_arrModules['']=true;g_arrModules['']=true;$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Linux",c6:"Article: How-To",c15:"3208389"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js?v=20170717114015"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"idgnetworkworldprod";s.pageName="NetworkWorld:article:howto:Linux:3208389:Unix: How random is random?";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:networkworld";s.eVar1="D=c1";s.prop2="content type:howto";s.eVar2="D=c2";s.prop3="display type:article:howto";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop5="blog";s.prop6="";s.prop7="blogs:unix as a second language";s.eVar7="D=c7";s.prop9="category:linux";s.eVar9="D=c9";s.prop11="published:17-Jul-17";s.eVar11="D=c11";s.prop12="aid:3208389";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:sandra henry-stocker";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3208389/linux/unix-how-random-is-random.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:nww:howto:networkworld:article:howto:linux:3208389:unix: how random is random?";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="blog";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="3353";s.eVar53="D=c53";s.prop54="linux,security";s.eVar30="D=c54";s.eVar33=s.prop55="3353,2206";s.eVar33="D=c55";s.prop56="programmers";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop63="notapplicable";s.prop74="architecture";s.eVar58="D=c74";s.prop75="operating-systems";s.eVar60="D=c75";s.prop58="architecture:operating-systems";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="17-Jul-17";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://idgenterprise.d1.sc.omtrdc.net/b/ss/idgnetworkworldprod/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="networkworld.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<script type="text/javascript">$thm.logPlEvent({"b":"nww","e":"view","t":"article","id":"3208389"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
</body>
</html>