Skip Links

When the wireless to a satellite connection is slow

Nutter's Help Desk By Ron Nutter, Network World
April 28, 2008 09:36 AM ET

Network World - I am running Windows Vista. I have a satellite Internet connection. The modem is connected to my computer. I purchased a D-Link Router model WBRr-2310. I am connecting at a speed of about 1300 bps, but the other 3 computers that use the router connect at exactly 54 Mbps only. I connected my laptop directly to the modem and it connected at about 1300 also. But when I went through the router again it went back to exactly 54 Mbps. I have exhausted tech support for the router and for my Internet connection. I have updated firmware, uninstalled and reinstalled and a half dozen other things they had me try but it didn't help. Have you any ideas?
-- Fhredi Wiemer

I think you have found the problem - it has to do with the connection that you are using. When you don't use the WBR-2310, you are using a copper-based connection using a network patch cable with RJ-45s on both ends going from the built-in network card on your laptop to the network jack on the satellite modem. That would have you connect at one speed depending on the speed supported by the network connection in the satellite modem. The WBR-2310 router also incorporates a wireless access point as a part of the router. When you are connecting that way, you are seeing an artificially high rate because of the wireless being Mode G - which, when everything is working right, will connect at 54 Mbps even though your satellite connection is much slower.

Something worth trying if the placement of your computer permits is to connect it via the 4-port switch on the back of the router and see if you get a difference in connection speed (you probably will).

To get a true idea of what your throughput is (as good as an idea as you can get with the IP latency that I have seen in the satellite connections I have tested), use a test site such as dslreports.com to see what your network throughput speed is versus the "connection" speed that is getting reported to you. Keep in mind that there usually is a difference between the connection speed and the actual throughput speed of the connection you are on. Since this is a satellite connection, you may have to take the numbers you get with a grain of salt. It would be good to talk to the satellite ISP folks and see if there is a network speed test site that they are comfortable with the results from or if there is a specific test site geared toward satellite connections. Try running the network speed tests from one computer using a wired and wireless connections. If you see a significant difference in speeds, this might indicate a problem in the D-Link router you have. See if the ISP folks know of a specific router that is "friendly" to this type of connection - or if any patches are required on your end. It might take a bit of experimenting using different combinations of speed and duplex to find something that will work with this type of connection.

Since you are using Vista, make sure that you have the latest patches installed. See if the satellite ISP is aware of any specific Vista configuration settings that you might need to alter to get optimum performance. Make sure that you have the latest network card drivers installed as well. If your computer allows, it might be worthwhile installed a different network card to see if your problems might be related to the network card installed in the computer. I don't think that this will make any difference but it is one thing that doesn't appear to have been tried at this point.

Our Commenting Policies
Latest News
rssRss Feed
View more Latest News