Chapter 4: Cisco MPLS Traffic Engineering

Cisco Press

1 2 3 4 5 6 7 8 Page 6
Page 6 of 8

Example 4-35 shows a different TE-Class definition using Cisco IOS XR. In this case, a CT1 TE LSP can preempt some CT0 TE LSPs and vice versa. However, Other TE LSPs cannot preempt CT1 TE LSPs corresponding to TE-Class 0. This configuration defines only a subset of the eight maximum TE-Classes you can specify.

Example 4-35  TE-Class Definition in Cisco IOS XR

mpls traffic-eng
 interface POS0/3/0/0
 !
 interface POS0/3/0/1
 !
 ds-te mode ietf
 ds-te te-classes
  te-class 0 class-type 1 priority 0
  te-class 1 class-type 0 priority 1
  te-class 2 class-type 1 priority 2
  te-class 3 class-type 0 priority 3
  te-class 4 unused 
  te-class 5 unused 
  te-class 6 unused 
  te-class 7 unused 
 !
!

Defining a DS-TE Tunnel Interface

Example 4-36 shows the configuration of two DS-TE tunnels in Cisco IOS. Tunnel1 signals CT1 with setup priority 0. The class-type keyword in the tunnel mpls traffic-eng bandwidth command instructs the node to use CT1. Tunnel2 signals Class-Type 0 with priority 7. These two tunnels correspond to TE-Class 0 and 7 in Example 4-34, respectively. The tunnel mpls traffic-eng bandwidth command defines CT0 TE LSPs by default if you do not specify the class-type (or sub-pool) keyword. The class type and priority that you configure for a tunnel must be consistent with your TE-Class definitions, and those definitions must be consistent throughout your DS-TE network.

Example 4-36 MPLS TE Tunnels Using DS-TE in Cisco IOS

interface Tunnel1
 description FROM-ROUTER-TO-DST1-CT1
 ip unnumbered Loopback0
 tunnel destination 172.16.255.131
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 0 0
 tunnel mpls traffic-eng bandwidth class-type 1 5000
 tunnel mpls traffic-eng path-option 20 dynamic
!
interface Tunnel2
 description FROM-ROUTER-TO-DST1-CT0
 ip unnumbered Loopback0
 tunnel destination 172.16.255.131
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 100000
 tunnel mpls traffic-eng path-option 20 dynamic
!

Example 4-37 shows the configuration of two DS-TE tunnels in Cisco IOS XR. The class-type keyword in the signalled-bandwidth command specifies the Class-Type to 1. If you do not use the sub-pool keyword, the node signals CT0 for the TE LSP. In this case, tunnel-te1 uses CT1 with priority 2, and tunnel-te2 uses CT0 with priority 3. Those combinations correspond to TE-Class 2 and 3 in Example 4-35, respectively. Again, the Class-Type and priorities that you configure for a tunnel must match a valid TE-Class, and your TE-Class definitions must be consistent throughout your DS-TE network.

Example 4-37 MPLS TE Tunnels Using DS-TE in Cisco IOS XR

interface tunnel-te1
 description FROM-ROUTER-TO-DST1-CT1 
 ipv4 unnumbered Loopback0 
 priority 2 2 
 signalled-bandwidth class-type 1 5000 
 destination 172.16.255.130 
 path-option 30 dynamic 
!
interface tunnel-te2
 description FROM-ROUTER-TO-DST1-CT0 
 ipv4 unnumbered Loopback0 
 priority 3 3 
 signalled-bandwidth 50000 
 destination 172.16.255.130 
 path-option 30 dynamic 
!

Configuring Bandwidth Constraints

You need to define the per-link bandwidth constraints throughout your DS-TE network. Cisco IOS supports the RDM and MAM. RDM is the default bandwidth constraints mode. You use the mpls traffic-eng ds-te bc-model mam command to enable MAM. The ip rsvp bandwidth interface command specifies the bandwidth constraints for a link. The command uses the rdm and mam keywords to associate the constraints to a particular model. For RDM, the first bandwidth amount in the command specifies BC0. A second bandwidth amount following the sub-pool keyword specifies BC1. For MAM, you use the max-reservable-bw keyword to define the maximum reservable bandwidth. The bc0 and bc1 keywords enable you to specify BC0 and BC1, respectively. You can also specify BC1 with the sub-pool keyword.

Example 4-38 shows the configuration of the RDM bandwidth constraints that two interfaces will enforce. In this case, interface POS0/1/0 has a BC0 of 100,000 kbps and a BC1 of 0. Interface POS1/0/0 has a BC0 of 155,000 kbps and a BC1 of 55,000 kbps.

Example 4-38 Interfaces Using DS-TE with RDM in Cisco IOS

interface POS0/1/0
 ip address 172.16.0.0 255.255.255.254
 mpls traffic-eng tunnels
 ip rsvp bandwidth rdm bc0 100000
!
interface POS1/0/0
 ip address 172.16.0.2 255.255.255.254
 mpls traffic-eng tunnels
 ip rsvp bandwidth rdm bc0 155000 bc1 55000
!

Example 4-39 illustrates the configuration of MAM in Cisco IOS. In this case, both interfaces POS0/1/0 and POS1/0/0 have a maximum reservable bandwidth of 155,000 kbps. Interface POS0/1/0 divides the maximum reservable bandwidth in 100,000 kbps for BC0 and 55,000 for BC1. Interface POS1/0/0 uses a different approach where both BC0 and BC1 are 90,000 kbps and their sum exceeds the maximum reservable bandwidth. These constraints facilitate bandwidth sharing between CT0 and CT1 on this interface.

Example 4-39  Interfaces Using DS-TE with MAM in Cisco IOS

mpls traffic-eng ds-te bc-model mam
!
interface POS0/1/0
 ip address 172.16.0.0 255.255.255.254
 mpls traffic-eng tunnels
 ip rsvp bandwidth mam max-reservable-bw 155000 bc0 100000 bc1 55000
!
interface POS1/0/0
 ip address 172.16.0.2 255.255.255.254
 mpls traffic-eng tunnels
 ip rsvp bandwidth mam max-reservable-bw 155000 bc0 90000 bc1 90000
!

Cisco IOS XR also supports both RDM and MAM. You select the bandwidth constraint model using the ds-te bc-model command, with RDM being the default model. You specify BC0 with the bc0 keyword in the bandwidth interface command under the rsvp configuration mode. The bc1 keyword defines BC1. The same bandwidth command specifies the model the bandwidth constraints apply to with the rdm and mam keywords. The model you configure on the node must match the model you configure with the bandwidth command. When you define MAM constraints, the max-reservable-bw keyword defines the maximum reservable bandwidth on the interface.


Note - Consult the software documentation for the most updated information on the number of bandwidth constraints that a particular device can support.


Example 4-40 shows the configuration of RDM in Cisco IOS XR. In this case, interface POS0/3/0/0 has a BC0 of 155,000 kbps and a BC1 value of 55,000 kbps. Interface POS0/3/0/1 has a slightly different configuration with a BC0 of 100,000 kbps and a BC1 of 55,000 kbps.

Example 4-40 Interfaces Using DS-TE with RDM in Cisco IOS XR

rsvp
 interface POS0/3/0/0
  bandwidth rdm bc0 155000 bc1 55000
 !
 interface POS0/3/0/1
  bandwidth rdm bc0 100000 bc1 55000
 !
!

Example 4-41 illustrates the configuration of MAM in Cisco IOS XR. Interface POS0/3/0/0 has a maximum reservable bandwidth of 155,000 kbps, a BC0 of 100,000 kbps, and a BC1 of 100,000 kbps. Interface POS0/3/0/1 has a maximum reservable bandwidth of 155,000 kbps, a BC0 of 100,000 kbps, and a BC1 of 55,000 kbps. Notice that for interface POS0/3/0/0, the sum of the two bandwidth constraints is higher than the maximum reservable bandwidth to improve bandwidth sharing acess CTs with this model.

Example 4-41 Interfaces Using DS-TE with MAM in Cisco IOS XR

rsvp
 interface POS0/3/0/0
  bandwidth mam max-reservable-bw 155000 bc0 100000 bc1 100000
 !
 interface POS0/3/0/1
  bandwidth mam max-reservable-bw 155000 bc0 100000 bc1 55000
 !
!
mpls traffic-eng
 interface POS0/3/0/0
 !
 interface POS0/3/0/1
 !
 ds-te mode ietf
 ds-te bc-model mam
!

Verifying DS-TE Link Information Distribution

DS-TE slightly modifies existing verification and debug commands instead of introducing new ones. Therefore, you continue to use the troubleshooting commands that previous verification sections discussed, primarily show mpls traffic-eng link-management advertisements, show mpls traffic-eng topology, and show mpls traffic-eng tunnels.

Example 4-42 illustrates the modification that DS-TE introduces to the output of the show mpls traffic-eng topology command in Cisco IOS. Similarly, Example 4-43 illustrates the output of the show mpls traffic-eng topology command in Cisco IOS XR when you enable DS-TE. Notice that both outputs highlight the bandwidth constraint model, the bandwidth constraint values, and the bandwidth available for each of the TE-Classes for each link.

Example 4-42 Examining the MPLS TE Topology Database with DS-TE Enabled in Cisco IOS

Router#show mpls traffic-eng topology 172.16.255.1

IGP Id: 172.16.255.1, MPLS TE Id:172.16.255.1 Router Node (ospf 100 area 0) id 1
     link[0]: Point-to-Point, Nbr IGP Id: 172.16.255.131, nbr_node_id:2, gen:121
         frag_id 0, Intf Address:172.16.0.2, Nbr Intf Address:172.16.0.3
         TE metric:1, IGP metric:1, attribute flags:0x0
         SRLGs: None 
         physical_bw: 155000 (kbps), 

         BC Model Id: RDM
         BC0 (max_reservable): 155000 (kbps)
         BC0 (max_reservable_bw_global): 155000 (kbps)
         BC1 (max_reservable_bw_sub): 55000 (kbps)

                  Total Allocated  Reservable
                  BW (kbps)        BW (kbps)
                  ---------------  -----------
    TE-Class[0]:       5000           50000
    TE-Class[1]:       5000           50000
    TE-Class[2]:       5000           50000
    TE-Class[3]:       5000           50000
    TE-Class[4]:       5000          150000
    TE-Class[5]:       5000          150000
    TE-Class[6]:       5000          150000
    TE-Class[7]:     105000           50000
     
! Output omitted for brevity

Example 4-43 Examining the MPLS TE Topology Database with DS-TE Enabled in Cisco IOS XR

RP/0/4/CPU0:Router#show mpls traffic-eng topology 172.16.255.129
My_System_id: 172.16.255.129 (ospf DEFAULT area 0)
My_BC_Model_Type: RDM 

Signalling error holddown: 10 sec Global Link Generation 481

IGP Id: 172.16.255.129, MPLS TE Id: 172.16.255.129 Router Node (ospf DEFAULT area 0)

 Link[0]:Point-to-Point, Nbr IGP Id:172.16.255.130, Nbr Node Id:28, gen:481
   Frag Id:0, Intf Address:172.16.192.0, Intf Id:0
    Nbr Intf Address:172.16.192.1, Nbr Intf Id:0
   TE Metric:1, IGP Metric:1, Attribute Flags:0x0
   Switching Capability:, Encoding:
   BC Model ID:RDM
   Physical BW:155520 (kbps), Max Reservable BW:100000 (kbps)
   BC0:100000 (kbps) BC1:55000 (kbps)
                 Total Allocated  Reservable
                 BW (kbps)        BW (kbps)
                 ---------------  -----------
    TE-class[0]:            0        55000
    TE-class[1]:            0       100000
    TE-class[2]:         5000        50000
    TE-class[3]:        55000        45000
    TE-class[4]:            0            0
    TE-class[5]:            0            0
    TE-class[6]:            0            0
    TE-class[7]:            0            0

! Output omitted for brevity

Verifying Signaling of DS-TE LSPs

DS-TE does not define new commands to verify the signaling of TE LSPs. As described in section "Verifying Signaling of TE LSPs," the show mpls traffic-eng tunnels, show ip rsvp sender detail, and show ip rsvp reservation detail commands provide all the signaling details for a TE LSP in Cisco IOS. Cisco IOS XR provides the equivalent show mpls traffic-eng tunnels, show rsvp sender detail, and show rsvp reservation detail commands. When you use DS-TE, those commands provide similar output and specify the CT that the TE LSP uses.

Fast Reroute (FRR)

Cisco IOS and Cisco IOS XR provide FRR for link and node protection. Both operating systems use the facility technique because of its superior scalability. You can use FRR with regular TE LSPs or DS-TE LSPs. In addition, you can configure your network to provide connectivity protection or bandwidth protection to make sure that backup tunnels have sufficient capacity before the point of local repair (PLR) selects them to protect a primary TE LSP. To deploy FRR, you must configure the headend of the primary tunnel to request protection-and you must configure at least one midpoint with a backup tunnel to reroute the primary TE LSPs. The backup tunnel must be a next hop (NHOP) or next-next hop (NNHOP) tunnel that bypasses the failure and intersects the primary TE LSP.

You need to configure which TE LSPs require protection with FRR. Cisco IOS uses the tunnel mpls traffic-eng fast-reroute command that you need to apply on the MPLS TE tunnel interface at the headend. The node-protect and bw-protect keywords are optional and set the corresponding node protection desired and bandwidth protection desired flags in the signaling of the primary TE LSP. Cisco PLRs attempt to provide the best protection possible to a primary TE LSP even if you do not set these flags. Cisco IOS XR uses the fast-reroute command on the MPLS TE tunnel to signal that the TE LSP desires protection. Examples 4-44 and 4-45 show MPLS TE tunnels in Cisco IOS and Cisco IOS XR that request FRR protection.

Example 4-44 Tunnel Requesting FRR with Node and Bandwidth Protection in Cisco IOS

interface Tunnel1
 description FROM-ROUTER-TO-DST1-FRR-NODEP-BWP
 ip unnumbered Loopback0
 tunnel destination 172.16.255.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 20000
 tunnel mpls traffic-eng path-option 10 explicit name PATH2
 tunnel mpls traffic-eng fast-reroute bw-protect node-protect
!

Example 4-45 Tunnel Requesting FRR Protection in Cisco IOS XR

interface tunnel-te1
 description FROM-ROUTER-TO-DST1-FRR
 ipv4 unnumbered Loopback0
 priority 3 3
 signalled-bandwidth 30000 class-type 1
 destination 172.16.255.2
 fast-reroute
 path-option 10 explicit name PATH1
!
Related:
1 2 3 4 5 6 7 8 Page 6
Page 6 of 8
SD-WAN buyers guide: Key questions to ask vendors (and yourself)