Chapter 7: Improving and Maintaining Voice Quality

Cisco Press

1 2 3 4 5 6 Page 6
Page 6 of 6
  • Locations CAC—The locations feature provides CAC for centralized call-processing systems. A centralized system uses a single CCM cluster to control all of the locations. CCM's locations feature allows you to specify the maximum amount of bandwidth available for calls to and from each location, thereby limiting the number of active calls and preventing oversubscription of the bandwidth on the IP WAN links.

  • Gatekeeper zone CAC—A gatekeeper device provides CAC for distributed call-processing systems. In a distributed system, each site contains its own call-processing capability. Calls are limited between zones in this configuration.

Summary

This chapter introduced the need for quality of service (QoS) in a converged network environment (that is, a network that simultaneously transports voice, data, and/or video). In the absence of QoS mechanisms, voice packets might suffer from packet loss, packet delay, and variable delay (that is, jitter). QoS mechanisms help mitigate such challenges through tools such as classification, marking, low latency queuing (LLQ), RTP Header Compression (cRTP), and Link Fragmentation and Interleaving (LFI).

Even with its relatively high-speed connectivity, local area networks (LANs) also need QoS. For example, an interface speed mismatch for traffic entering (for example, on a 1 Gbps link) and exiting (for example, on a 100 Mbps link) a switch could cause a switch interface queue to fill to capacity and overflow. On the LAN, many Cisco Catalyst switches can use QoS mechanisms, such as weighted round-robin (WRR) and CoS to DSCP remarking.

While the study of how to configure the various aspects of QoS mechanisms is beyond the scope of this book, this chapter did introduce a way to configure QoS on both IOS router platforms and IOS-based Catalyst switch platforms, through a feature called AutoQoS.

In the voice arena, most QoS mechanisms are aimed at protecting voice from data. However, too many simultaneous voice calls can also oversubscribe available WAN bandwidth. Therefore, Call Admission Control (CAC) mechanisms help protect voice from voice. This chapter discussed the configuration of H.323, SIP, MGCP, and Cisco Unified CallManager CAC approaches.

Chapter Review Questions

The following questions test your knowledge of topics explained in this chapter. You can find the answers to the questions in Appendix A, "Answers to Chapter Review Questions."

  1. Which two factors affect voice clarity?

    1. Fidelity

    2. Echo

    3. Sidetone

    4. Background noise

    5. Distance

  2. Identify two broad categories of delay under which more specific types of delay are categorized?

    1. Variable delay

    2. Serialization delayfixed delay

    3. FIFO delay

    4. Processing delay

  3. According to ITU-T Recommendation G.114, how much delay is acceptable for most user applications?

    1. 0 to 150 ms

    2. 200 to 250 ms

    3. 150 to 400 ms

    4. Above 400 ms

  4. Which of the following QoS mechanisms does the AutoQoS feature enable on a Catalyst switch port?

    1. LFI

    2. cRTP

    3. WRR

    4. LLQ

  5. What Cisco IOS software feature allows AutoQoS for Enterprise to dynamically discover an interface's traffic patterns?

    1. NBAR

    2. ACLs

    3. CEF

    4. CBAC

  6. Which of the following interface configuration mode commands enables AutoQoS on an interface and instructs the interface to trust Layer 2 CoS priority markings only if those CoS markings came from a Cisco IP phone?

    1. auto qos voip device cisco-phone

    2. auto qos voip cisco-phone

    3. auto qos voip trust cos

    4. auto qos voip trust cisco-phone

  7. If CAC and LLQ are enabled on a link, which traffic will be transmitted first?

    1. Small data packets

    2. Large data packets

    3. Voice packets

    4. Packets that arrived first

  8. At what location in the network are CAC call control services configured?

    1. Incoming gateway

    2. Outgoing gateway

    3. Incoming gatekeeper

    4. Outgoing gatekeeper

    5. Entire network

  9. With the _______________________ command, you can configure two thresholds, high and low, for each resource.

    1. call spike

    2. call threshold

    3. call treatment

    4. rtr responder

  10. Which feature of Cisco Unified CallManager allows you to specify the maximum bandwidth available for calls to and from each location?

    1. Set bandwidth

    2. Locations

    3. Gatekeeper zone

    4. Active calls

Lab Exercise: Router AutoQoS

In this lab, you will configure AutoQoS on two different router interfaces. One interface runs at a speed of 128 kbps, and the other interface runs at a speed of 2 Mbps. You will see that AutoQoS treats these interfaces differently, based on their available bandwidth.

Specifically, you will configure router R2, as shown in Figure 7-8. The interface speeds were configured in the "Initial Configuration" task of the lab exercise in Chapter 2, "Analog and Digital Voice Connections."

Figure 7.8

Figure 7-8

Lab Topology

Task 1: Configure AutoQoS on the Slower Interface

In this task, you will configure AutoQoS on router R2's slower serial interface.

Complete these steps:

Step 1. Enter interface configuration mode on router R2 for the interface that connects R2 to router R1 (for example, interface Serial 0/0 in Figure 7-8).

Step 2. Enable AutoQoS for this interface with the auto qos voip command.

Task 2: Configure AutoQoS on the Faster Interface

In this task, you will configure AutoQoS on router R2's faster serial interface.

Complete these steps:

Step 1. Enter interface configuration mode on router R2 for the interface that connects R2 to router R3 (for example, interface Serial 0/1 in Figure 7-8).

Step 2. Enable AutoQoS for this interface with the auto qos voip command.

Task 3: Exercise Verification

In this task, you will verify the configuration of AutoQoS on router R2's serial interfaces.

Complete these steps:

Step 1. From router R2's privileged mode, enter the show auto qos command to view the commands entered by AutoQoS globally, for the slower serial interface, and for the faster serial interface.

Step 2. Notice that for the slower serial interface, AutoQoS configured Multilink PPP (MLP) and enabled RTP Header Compression (cRTP) because these are link efficiency mechanisms designed to optimize bandwidth usage on slower-speed serial interfaces (that is, interfaces with interface speeds less than 768 kbps).


Note - The purpose of this lab is to illustrate how AutoQoS intelligently applies appropriate QoS mechanisms to interfaces, based on interface characteristics. In order to be able to place a phone call across the lab topology after completing this lab, you should also configure AutoQoS on router R1's serial interface that connects back to router R2, because MLP must be configured on both ends of a link.


Suggested Solution

Although your physical hardware might differ, Example 7-7 shows the output of the show auto qos command on R2 after entering the auto qos voip command for interfaces Serial 0/0 and Serial 0/1. Notice that cRTP and MLP are enabled only for interface Serial 0/0 since these link efficiency mechanisms are appropriate for slower link speeds (that is, link speeds less than 768 kbps), such as Serial 0/0's link speed of 128 kbps. However, these link efficiency mechanisms are not appropriate for higher-speed links (that is, link speeds equal to or greater than 768 kbps), such as Serial 0/1's link speed of 2 Mbps.

Example 7-7 Output from the show auto qos Command on R2

R2#show auto qos 
 !
 ip access-list extended AutoQoS-VoIP-RTCP
  permit udp any any range 16384 32767
 !
 ip access-list extended AutoQoS-VoIP-Control
  permit tcp any any eq 1720 
  permit tcp any any range 11000 11999 
  permit udp any any eq 2427 
  permit tcp any any eq 2428 
  permit tcp any any range 2000 2002 
  permit udp any any eq 1719 
  permit udp any any eq 5060
 !
 class-map match-any AutoQoS-VoIP-RTP-UnTrust 
  match protocol rtp audio 
  match access-group name AutoQoS-VoIP-RTCP 
 !
 class-map match-any AutoQoS-VoIP-Control-UnTrust 
  match access-group name AutoQoS-VoIP-Control 
 !
 class-map match-any AutoQoS-VoIP-Remark 
  match ip dscp ef 
  match ip dscp cs3 
  match ip dscp af31 
 !
  policy-map AutoQoS-Policy-UnTrust 
  class AutoQoS-VoIP-RTP-UnTrust 
   priority percent 70 
   set dscp ef 
  class AutoQoS-VoIP-Control-UnTrust 
   bandwidth percent 5 
   set dscp af31 
  class AutoQoS-VoIP-Remark 
   set dscp default 
  class class-default 
   fair-queue 

 Serial0/0 -
 !
 interface Serial0/0 
  no ip address 
  encapsulation ppp
  no fair-queue 
  ppp multilink
  ppp multilink group 2001100114
 ! 
 interface Multilink2001100114
  bandwidth 128
  ip address 10.1.1.1 255.255.255.0
  service-policy output AutoQoS-Policy-UnTrust
  ppp multilink
  ppp multilink fragment delay 10
  ppp multilink interleave
  ppp multilink group 2001100114
  ip rtp header-compression iphc-format

 Serial0/1 -
 !
  interface Serial0/1
  service-policy output AutoQoS-Policy-UnTrust
 !
 rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Dr 
ops" owner AutoQoS
 rmon alarm 33333 cbQosCMDropBitRate.1081.1083 30 absolute rising-threshold 1 3  
3333 falling-threshold 0 owner AutoQoS
 rmon alarm 33334 cbQosCMDropBitRate.1137.1139 30 absolute rising-threshold 1 3
3333 falling-threshold 0 owner AutoQoS

Note - LLQ is appropriate for all interface speeds and is configured for both interfaces.


Copyright © 2007 Pearson Education. All rights reserved.

Learn more about this topic

 
Join the Network World communities on Facebook and LinkedIn to comment on topics that are top of mind.
Related:

Copyright © 2008 IDG Communications, Inc.

1 2 3 4 5 6 Page 6
Page 6 of 6
SD-WAN buyers guide: Key questions to ask vendors (and yourself)