
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="no-js lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="no-js lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Canonical&#039;s eyes are on IoT | Network World</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html"/>
<meta itemprop="url" content="https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html"/>
<meta name="description" content="Canonical executive vice president Mike Bell talks to Network World about the open source software company&#039;s move to take its place in enterprise IoT."/>
<meta name="news_keywords" content="Canonical,Ubuntu,Linux,open source"/>
<meta name="DC.date.issued" content="2017-09-28T12:28-05:00"/>
<meta name="date" content="2017-09-28"/>
<link rel="amphtml" href="https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.amp.html"/>
<meta property="og:title" content="Canonical&#039;s eyes are on IoT">
<meta property="og:image" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg"/>
<link rel="image_src" href="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg"/>
<meta name="twitter:image" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Jon Gold">
<meta property="og:site_name" content="Network World"/>
<meta property="fb:app_id" content="147094931979429"/>
<meta property="og:url" content="https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html">
<!-- Use Twitter Summary Card with Large Image for articles and videos -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@networkworld">
<meta property="og:description" content="Canonical executive vice president Mike Bell talks to Network World about the open source software company&#039;s move to take its place in enterprise IoT.">
<meta name="twitter:description" content="Canonical executive vice president Mike Bell talks to Network World about the open source software company&#039;s move to take its place in enterprise IoT.">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="google-site-verification" content="OnAuriQCKcyQ0EoVwZP5SB1dhrHOFhHpUzZ21n9viHM"/>
<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="internet-of-things,open-source-tools,jon-gold,news,medium"/>
<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg"/>
<meta name="sailthru.title" content="Canonical&#039;s eyes are on IoT"/>
<meta name="sailthru.description" content="Canonical executive vice president Mike Bell talks to Network World about the open source software company&#039;s move to take its place in enterprise IoT."/>
<meta name="displaytype" content="article"/>
<meta name="source" content="network world"/>
<meta name="category" content="internet of things,open source"/>
<meta name="storytype" content="news"/>
<!-- pagination -->
<link rel="stylesheet" href="/www.idge/css/inline-header.css?v=20170927115126"/>
<link rel="stylesheet" href="/www.idge.nww/css/inline-header.css?v=20170927115126"/>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css?v=20170927115126"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css?v=20170927115126"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www.idge/css/article.css?v=20170927115126"/>
<link rel="stylesheet" href="/www.idge/css/print.css?v=20170927115126" media="print"/>
<link rel="stylesheet" href="/www.idge.nww/css/article.css?v=20170927115126"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css?v=20170927115126"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css?v=20170927115126"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<script>try{performance.mark("mark_head_css_done_blocking");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<link href="//fonts.googleapis.com/css?family=Source+Sans+Pro:400,700,400italic,700italic" rel="stylesheet" type="text/css"/>
<script type="text/javascript" src="//fonts.staticworld.net/lbi2kpq.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="/www.idge.nww/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://idge.staticworld.net/nww/nww_logo_144x144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://idge.staticworld.net/nww/nww_logo_114x114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://idge.staticworld.net/nww/nww_logo_72x72.png"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://idge.staticworld.net/nww/nww_logo_57x57.png"/>
<link rel="apple-touch-icon" href="https://idge.staticworld.net/nww/nww_logo_300x300.png"/>
<!-- js -->
<script src="/www.idge/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js?v=20170927115126"></script>
<!-- google_dfp needs jquery defined first -->
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20170927115126"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script src="/www/js/ads/narf_prebid.js?v=20170927115126"></script>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js?v=20170927115126"></script>
<!-- End of LiveRamp -->
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_NetworkWorld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"internet-of-things_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article/internet-of-things');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3229008');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'news');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'2');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("manufacturer",'canon');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3340,3248]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['internet-of-things','open-source-tools']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Jon Gold');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript">console.log("PROXIMIC RESPONSE: PAGE-LEVEL");(function(){try{var proximic_data={"data":["300003","131100","131121","121100","112200","131132","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","20f4sh","q1mw3z","bkwp85","enwcef","26kvj2","bsuu95","yhfsd1","x8eev1","ibwrkt","9v0tiu","qh9ovz","skl8g2","1ynb20","e2co9k","folvaf","z7xuj9","44ywyv","2ew8ed","3nbmlu","0gef9p","xks7sj","yn3dkv","agtqg7","7grvv1","agt9m3","pcz604","le330e","64l66x","500187","500188","500218","500235","500230","500238","500247","500234","500241"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20170927115126"></script>
<script type="text/javascript">$thm.useBusinessData=true;</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"2619":"07dd"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451478":"6353218"));IDG.GPT.addBiddingParams("TriLiftPrefix","network world_ros_");}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script type="text/javascript" src="/www/js/ads/prebid_gpt_launcher.js?v=20170927115126"></script>
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="nww";var brandName="Network World";var regDebugLog=false;var regApiUrl="https://regdev.idge.int/api/";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".networkworld.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="https://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js?v=20170927115126"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20170927115126"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<!-- All JavaScript at the bottom, except for Modernizr which enables HTML5 elements & feature detects -->
<script src="/www.idge/js/mule/modernizr.js?v=20170927115126"></script>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"article",eloqua_topic:"web20"};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var g_arrModules=new Array();</script>
<meta name="parsely-title" content="Canonical's eyes are on IoT"/>
<meta name="parsely-link" content="https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.3x2.jpg"/>
<meta name="parsely-pub-date" content="2017-09-28T19:28:00Z"/>
<meta name="parsely-section" content="Internet of Things"/>
<meta name="parsely-author" content="Jon Gold"/>
<meta name="parsely-tags" content="type: news,source: networkworld,imported"/>
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script>dataLayer=[{'primaryCategory':'Internet of Things','ga_enabled':'true','gaTrackingId':'UA-230061-1','articleType':'News','articleId':'3229008','articleDisplayId':'1','articleTitle':'Canonical\'s eyes are on IoT','articleAuthor':'Jon Gold','datePublished':'Thu Sep 28 12:28:00 PDT 2017','isInsider':'false','blogName':'','parselyEnabled':'true','parselyDomain':'networkworld.com','skimlinksId':'111346X1569477','sailthruCustomerId':'5fb8d6c0731a8bb2f3ec7f437fe7404e','geolocEnabled':'true'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html";_sf_async_config.title="Canonical\&#039;s eyes are on IoT | Network World";_sf_async_config.domain="networkworld.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="internet-of-things";_sf_async_config.authors="Jon Gold";</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-P3S27S" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P3S27S');</script>
<!-- End Google Tag Manager -->
<script>try{performance.mark("mark_head_js_done_blocking");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
</head>
<body id="article3229008" class="article network world">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<div class="ad-header">
<div class="brand-logo"></div>
<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
</div>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
<!-- blx4 #809 blox4.raw_link_list  -->
<ul>
<li><a href="/article/3197415/security/how-to-maintain-data-oversight-to-avoid-shadow-data.html">How to avoid ‘shadow data’</a></li>
<li><a href="/article/3197575/software/tpus-googles-machine-learning-pipeline-explained.html">Google’s machine-learning cloud pipeline</a></li>
<li><a href="/article/3196984/application-development/the-emergence-of-devops-in-the-evolving-digital-enterprise.html">DevOps in the digital enterprise</a></li>
<li><a href="/article/3196856/cloud-computing/how-to-avoid-downtime-and-disruption-when-moving-data.html">Disruption when moving data</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
</ul>
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/networkworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/network-world" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="http://www.facebook.com/#!/pages/Network-World/40168412104" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+networkworld/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/about/rss.html" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">network world</span></a>
<!--
	            	<img class="print-only" src="/www.idge.nww/images/networkworld-logo-print.png">
	            	-->
<img class="print-only" src="//idge.staticworld.net/nww/networkworld-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
<div class="insider-signin">
<span class="signin-register">
<a href="/learn-about-insider/"><span class="insider"></span></a> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> <span class="divider">|</span> <a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
</span>
<div id="welcome-message" class="insider-list">
<div id="insider-selector">
<div id="insider-welcome" class="label"></div>
<div class="stories">
<div class="personalization">Hi<span id="person-first-name"></span>! Here are the latest Insider stories.</div>
<ul>
<li><a href="/article/3225284/backup-recovery/review-4-top-disaster-recovery-platforms-compared.html">REVIEW: 4 top disaster-recovery platforms compared</a></li>
<li><a href="/article/3224465/mobile-wireless/review-mojo-wireless-intrusion-prevention-system.html">REVIEW: Mojo wireless intrusion prevention system</a></li>
<li><a href="/article/3222672/internet-of-things/review-microsoft-azure-iot-suite.html">Review: Microsoft Azure IoT Suite</a></li>
<li><a href="/article/3221393/linux/review-considering-oracle-linux-is-a-no-brainer-if-you-re-an-oracle-shop.html">Review: Considering Oracle Linux is a no-brainer if you’re an Oracle shop</a></li>
</ul>
<div class="sign-out-link">
<a class="more-insider" href="/insider/">More Insider</a>
<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
</div>
</div>
</div>
</div>
</div>
<script>$('.signin-register').hide();$('#welcome-message').hide();</script>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/careers/" class="hasChildren">Careers<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/careers/">All Careers</a></li>
<li><a href="/category/education/">Education</a></li>
<li><a href="/category/salary/">Salaries</a></li>
<li><a href="/category/it-skills-training/">Skills and Training</a></li>
</ul>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/data-center/" class="hasChildren">Data Centers<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/data-center/">All Data Centers</a></li>
<li><a href="/category/business-continuity/">Business Continuity</a></li>
<li><a href="/category/green-it/">Green IT</a></li>
<li><a href="/category/network-storage/">Network Storage</a></li>
<li><a href="/category/computers/">PCs</a></li>
<li><a href="/category/servers/">Server Hardware</a></li>
<li><a href="/category/tablets/">Tablets</a></li>
<li><a href="/category/virtual-desktop/">Virtual Desktop</a></li>
</ul>
</li>
<li><a href="/category/disaster-recovery/">Disaster Recovery</a>
</li>
<li><a href="/category/home-tech/">Home Tech</a>
</li>
<li><a href="/category/hybrid-cloud/">Hybrid Cloud</a>
</li>
<li><a href="/category/internet-of-things/">Internet of Things</a>
</li>
<li><a href="/category/infrastructure/" class="hasChildren">Infrastructure Management<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/infrastructure/">All Infrastructure Management</a></li>
<li><a href="/category/application-performance-management/">Application Performance Management</a></li>
<li><a href="/category/asset-management/">Asset Management</a></li>
<li><a href="/category/network-management/">Network Management</a></li>
<li><a href="/category/system-management/">System Management</a></li>
</ul>
</li>
<li><a href="/category/linux/">Linux</a>
</li>
<li><a href="/category/mobile-wireless/" class="hasChildren">Mobile &amp; Wireless<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/mobile-wireless/">All Mobile &amp; Wireless</a></li>
<li><a href="/category/android/">Android</a></li>
<li><a href="/category/byod/">BYOD</a></li>
<li><a href="/category/cellular-networks/">Cellular Networks</a></li>
<li><a href="/category/mdm-mam/">MDM</a></li>
<li><a href="/category/mobile-apps/">Mobile Apps</a></li>
<li><a href="/category/smartphones/">Smartphones</a></li>
<li><a href="/category/ios/">iOS</a></li>
</ul>
</li>
<li><a href="/category/lan-wan/" class="hasChildren">Networking<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/lan-wan/">All Networking</a></li>
<li><a href="/category/internet/">Internet</a></li>
<li><a href="/category/router/">Routers</a></li>
<li><a href="/category/telecommunication/">Service Providers</a></li>
<li><a href="/category/wan-optimization/">WAN Optimization</a></li>
<li><a href="/category/wi-fi/">Wi-Fi</a></li>
</ul>
</li>
<li><a href="/category/software-defined-networking/">SDN</a>
</li>
<li><a href="/category/security/" class="hasChildren">Security<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/security/">All Security</a></li>
<li><a href="/category/application-security/">Application Security</a></li>
<li><a href="/category/compliance/">Compliance</a></li>
<li><a href="/category/malware-cybercrime/">Cyber Crime</a></li>
<li><a href="/category/endpoint-protection/">Endpoint Protection</a></li>
<li><a href="/category/mobile-security/">Mobile Security</a></li>
<li><a href="/category/network-security/">Network Security</a></li>
</ul>
</li>
<li><a href="/category/small-business/">Small Business</a>
</li>
<li><a href="/category/software/" class="hasChildren">Software<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/software/">All Software</a></li>
<li><a href="/category/big-data-business-intelligence/">Big Data</a></li>
<li><a href="/category/crm/">CRM</a></li>
<li><a href="/category/erp/">ERP</a></li>
<li><a href="/category/windows/">Windows</a></li>
</ul>
</li>
<li><a href="/category/storage/">Storage</a>
</li>
<li><a href="/category/uc-voip/" class="hasChildren">Unified Communications<span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/category/uc-voip/">All Unified Communications</a></li>
<li><a href="/category/collaboration/">Collaboration</a></li>
<li><a href="/category/email/">Email</a></li>
<li><a href="/category/social-networking/">Social Networking</a></li>
<li><a href="/category/videoconferencing/">Videoconferencing</a></li>
<li><a href="/category/voip/">VoIP</a></li>
</ul>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
<li><a href="/category/wide-area-networking/">WAN</a>
</li>
<li><a href="/category/cisco-subnet/">Cisco Subnet</a>
</li>
<li><a href="/category/microsoft-subnet/">Microsoft Subnet</a>
</li>
<li><a href="/category/tech-primers/">Tech Primers</a>
</li>
</ul>
<ul class="secondary">
<li><a href="/news/">News</a></li>
<li><a href="/reviews/">Reviews</a></li>
<li><a href="/insider/">Insider</a></li>
<li><a href="/blogs/">Blogs</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="http://www.ereg.me/IDGEvents" target="_blank" rel="nofollow">Network World Events</a></li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>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</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/NewsArticle">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- blx4 #2264 blox4.html  -->
<div id="" class="blx blxPeventsheader blxM2264  blox4_html  blxC29681"> <style>
  .subnet-hdr-link {
    background-image:url('https://idge.staticworld.net/nww/Iot-subnet-banner-mobile.gif');
    background-repeat:no-repeat;
   	background-size: cover;
    height:53px;
    display:block;
    margin: 1rem 0 0;
  }
  
  @media only screen and (min-width: 48em) {
    .subnet-hdr-link {
        background-image:url('https://idge.staticworld.net/nww/Iot-subnet-banner.gif');
      background-size:970px 53px;
    }
  }
  header.cat {
     padding-top:0;
  }
</style>
<a href="/category/internet-of-things" class="subnet-hdr-link"></a> </div>
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/internet-of-things/" itemprop="url"><span itemprop="title">Internet of Things</span></a></li>
</ul>
</nav>
<div class="category"></div>
<h1 itemprop="headline">Canonical's eyes are on IoT</h1>
<script>try{performance.mark("mark_headline_rendered");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<section class="deck viewability">
<h3 itemprop="description">Canonical executive vice president Mike Bell talks about the open source software company's move to take its place in enterprise IoT</h3>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.networkworld.com%2Farticle%2F3229008%2Finternet-of-things%2Fcanonicals-eyes-are-on-iot.html&via=networkworld&text=Canonical%27s+eyes+are+on+IoT" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.networkworld.com%2Farticle%2F3229008%2Finternet-of-things%2Fcanonicals-eyes-are-on-iot.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.networkworld.com%2Farticle%2F3229008%2Finternet-of-things%2Fcanonicals-eyes-are-on-iot.html&title=Canonical%27s+eyes+are+on+IoT" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.networkworld.com%2Farticle%2F3229008%2Finternet-of-things%2Fcanonicals-eyes-are-on-iot.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.networkworld.com%2Farticle%2F3229008%2Finternet-of-things%2Fcanonicals-eyes-are-on-iot.html&title=Canonical%27s+eyes+are+on+IoT" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.networkworld.com%2Farticle%2F3229008%2Finternet-of-things%2Fcanonicals-eyes-are-on-iot.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){var eloquaParam={AssetCountforCurrentCampaign:"1",AssetName:"",AssetTopic:"",AssetType:"",BuyingCycle:"",C_Address1:"",C_Address2:"",C_BusPhone:"",C_City:"",C_Company_Size1:"",C_Country:"",C_EmailAddress:"",C_FirstName:"",C_Industry1:"",C_Job_Role1:"",C_LastName:"",C_State_Prov:"",C_Zip_Postal:"",ClientName:"",ProgramName:"",brand:"",elqFormName:"CentralRegistrationMasterForm",formId:"3062313",elqSiteId:1856,elqCustomerGUID:elqCustomerGUID,elqCookieWrite:0,friend_email:emailFrom,friend_article_title:"Canonical\'s eyes are on IoT",friend_taxo:"Internet of Things",friend_source:"Network World",friend_article_url:"https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html",device_platform:navigator.userAgent};$.ajax("https://secure.p01.eloqua.com/e/f2.aspx",{type:'GET',data:eloquaParam,success:function(data,textStatus,xhr){},error:function(xhr,textStatus,errorThrown){}});var eloquaParamMini={elqCustomerGUID:elqCustomerGUID,friend_taxo:"Internet of Things",friend_source:"Network World",device_platform:navigator.userAgent};formData+="&"+encodeQueryData(eloquaParamMini);$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=true&id=3229008">
<input type="hidden" name="title" value="Canonical\'s eyes are on IoT"/>
<input type="hidden" name="url" value="https://www.networkworld.com/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on Network World." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LdPbfsSAAAAAB89GpzHsyYe-AGzZXYy9K_4KAnF"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Jon-Gold/" rel="author" title="Jon Gold"><img class="bylineImage  imgId100304406 " src="https://images.techhive.com/images/article/2014/06/profile-100304406-byline.png" width="34" width="34" alt="Jon Gold" itemprop="image"/></a>
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Jon-Gold/"><span itemprop="name">Jon Gold</span></a></span>
</p>
<p class="dateline">
Senior Writer,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Network World</span><meta itemprop="logo" content="https://idge.staticworld.net/nww/nww_logo_300x300.png"/></span> <span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2017-09-28T12:28-0700">Sep 28, 2017 12:28 PM
PT
</span>
</p>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1"/>
<meta itemprop="height" content="467"/>
<meta itemprop="width" content="700"/>
<img src="https://images.idgesg.net/images/article/2017/09/wireless_network_management_gears_iot_internet_of_things_edge_computing_thinkstock_685417850_3x2_1200x800-100736489-large.jpg" alt="wireless network - internet of things edge [IoT] - edge computing" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
<script>try{performance.clearMarks("mark_primary_img_rendered");performance.mark("mark_primary_img_rendered");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<figcaption>
<span class="credit" itemprop="copyrightHolder">
Thinkstock
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">Related</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3213868/internet-of-things/3-real-world-examples-of-iot-rolled-out-in-the-enterprise.html"><img class="small.3x2Image  imgId100702324 " src="https://images.techhive.com/images/article/2017/01/network-782707_1280-100702324-small.3x2.jpg" alt="iot internet of things" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3213868/internet-of-things/3-real-world-examples-of-iot-rolled-out-in-the-enterprise.html">3 real-world examples of IoT rolled out in the enterprise</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3207535/internet-of-things/what-is-iot.html"><img class="small.3x2Image  imgId100728394 " src="https://images.idgesg.net/images/article/2017/07/thread_weave_colorful_network_web-100728394-small.3x2.jpg" alt="thread weave colorful network web" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3207535/internet-of-things/what-is-iot.html">What is IoT?</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3219858/cloud-computing/vmware-embraces-cloud-during-vmworld-ceo-gelsinger-says.html"><img class="small.3x2Image  imgId100733118 " src="https://images.idgesg.net/images/article/2017/08/nwin_016_vmwareceo_containers-100733118-small.3x2.jpg" alt="VMware CEO Pat Gelsinger" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3219858/cloud-computing/vmware-embraces-cloud-during-vmworld-ceo-gelsinger-says.html">VMware embraces cloud during VMWorld, CEO Gelsinger says</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/79495/whats-next-in-iot-innovations"><i class="ss-play"></i></a>
<a href="/video/79495/whats-next-in-iot-innovations"><img class="small.3x2Image  imgId100728157 " src="https://images.idgesg.net/images/article/2017/07/template-c100.00_02_04_04.still001-100728157-small.3x2.jpg" alt="space_telescope" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/79495/whats-next-in-iot-innovations">What&#039;s next in IoT innovations?</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push({'event':'loadTopCollectionModule'});</script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script>function gatherPerformanceMarks(){p=performance.getEntriesByType("mark");gtmEvent={'event':'gatherPerformanceMarks'};for(var i=0;i<p.length;i++){gtmEvent[p[i].name]=p[i].startTime;}var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push(gtmEvent);}</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>When Mark Shuttleworth founded Canonical in 2004, the idea behind the company was simple – promote the use of Ubuntu Linux as a desktop operating system. Fourteen years later, things have gotten a lot more complicated, as the prominent open source software vendor eyes the IoT market.</p><p>Canonical’s still flying the flag for desktop Linux, but the company’s real business is in the cloud – it claims that Ubuntu accounts for about 60% of all Linux instances in the major public clouds – and it’s hoping to make its mark in the next-buzziest part of the technology sector, the Internet of Things.</p><p>+<strong>ALSO ON NETWORK WORLD</strong>: <a href="https://www.networkworld.com/article/3229064/cpu-processors/nvidia-gets-broad-support-for-cutting-edge-volta-gpus-in-the-data-center.html">Nvidia gets broad support for cutting-edge Volta GPUs in the data center</a> + <a href="https://www.networkworld.com/article/3228119/data-center/a-lack-of-cloud-skills-could-cost-companies-money.html">A lack of cloud skills could cost companies money</a></p><p>According to Mike Bell, Canonical’s executive vice president for devices and IoT, the way businesses have begun to develop software for IoT devices has been advantageous for them – companies have started to take server or desktop distros and cut them down into software that works on embedded devices. Since Ubuntu is a familiar and well-known framework, it was a natural choice as a starting place. </p><aside class="nativo-promo smartphone" id=""> </aside><p>“We can see a growing market and it’s kind of a no-brainer that we needed to enter it,” Bell told <em>Network World</em>. “But we felt we had to do more than just cut down an operating system, so we focused on some of the main challenges facing embedded devices like security.”</p><p>That’s a well-known issue in IoT for a whole host of reasons, including the fact that embedded and IoT gizmos tend to be a lot more physically accessible than a server locked away in a data center, as well as the fact that they’re far less capable computing devices, less able to handle their own security.</p><p>Canonical developed Ubuntu Core, which the company pitches as a "tiny, transactional" version of the Linux OS. It's currently used across a wide range of device categories, from drones to aquaculture to signage. Canonical doesn’t sweat the very smallest-scale stuff on the IoT – Bluetooth-enabled lightbulbs aren’t high on the priority list for Ubuntu Core – but items with a little bit more capability are in the wheelhouse. Bell’s examples included everything from smart speakers, home and IoT gateways, to top-of-rack switches in the enterprise.</p><p>“We’re more into the architecture around security – isolation, containment, where the applications are restricted in what they can do unless you get the rights to do so – so we implement a level of access control at the kernel level,” he said.</p><aside class="nativo-promo tablet desktop" id=""> </aside><p>Software is the key weakness in the security stack for IoT, the product of rushed development cycles and an inability – or unwillingness to invest the necessary time and effort – to update some connected devices remotely. But that’s a problem that Linux is well-equipped to address, Bell notes.</p><p>“We have a whole division of people who are just focused on patching and security,” adding that that functionality doesn’t really scale well for a device maker. “Think of like a smart Wi-Fi camera on a building – if you break that through a bad update, you do not want to be getting a ladder out and all your customers having to pull them down off buildings – that’s something that doesn’t sit well with customers.”</p><p>One of the other big challenges facing enterprise IoT pros is quantifying the return on investment for any given opportunity, he argued. He offers the example of a refrigerator manufacturer that wants to add connective features to its products in order to glean a better understanding of how they’re used.</p><p>“You instinctively know that having telemetry on a device would be very useful and would help me in terms of product development, but without it, you don’t know what you don’t know,” Bell said.</p><p>Working with companies on IoT products has its challenges for a company unused to the marketplace, of course – Canonical is used to a relatively orderly 5-year support cycle for Ubuntu, but that’s often not enough time for enterprise IoT deployments, which can have lengthy potential service lives.</p><p>“You can get a legacy version of Ubuntu Server and buy another couple of years of support,” Bell said. “This is nothing new in the enterprise market, but yeah – when it comes to embedded applications, the challenges are different. We are getting to grips with that.”</p>
<div class="end-note">
<!-- blx4 #2005 blox4.html  -->
<div id="" class="blx blxParticleendnote blxM2005  blox4_html  blxC23909">Join the Network World communities on <a href="https://www.facebook.com/NetworkWorld/" target="_blank">Facebook</a> and <a href="https://www.linkedin.com/company/network-world" target="_blank">LinkedIn</a> to comment on topics that are top of mind.</div>
</div>
</div>
<script>try{performance.mark("mark_article_body_rendered");}catch(e){console.log("Error saving performance mark -- this function may not be supported in this browser");}</script>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/internet-of-things">Internet of Things</a></li>
<li><a href="/category/open-source-tools">Open Source</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">Jon covers open source, mobile, and network managment for Network World.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Jon-Gold/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="mailto:jgold@nww.com">
<i class="ss-icon ss-mail"></i>
</a>
</li>
<li>
<a href="https://twitter.com/NWWJonGold" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="https://plus.google.com/u/0/110325353278688341727/" class="googleplus-follow" target="_blank">
<i class="ss-icon ss-social ss-googleplus"></i>
</a>
</li>
<li>
<a href="/author/Jon-Gold/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<!-- blx4 #1524 blox4.article.toaster  -->
<div class="article-intercept">
<a href="http://www.networkworld.com/article/3161905/windows/10-new-ui-features-coming-to-windows-10.html#tk.cross_2nww_intrcpt">
<i class="ss-icon ss-navigateright"></i><em> Must read:</em> 10 new UI features coming to Windows 10
</a>
</div>
<script src="/www/js/video/embedder.js?v=20170927115126"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_9b336e"></div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30206;if(is_blocked===true){widget_id=30281;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="//trends.revcontent.com/serve.js.php?w=30206&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_9b336e");rcds.appendChild(rcel);});})();</script>
</div>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		
			
			
				$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
			
		
		if (Object.keys(IDG.GPT.companions).length > 0) {
		IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=954574976&iu=/8456/IDG.US_E_NetworkWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
INSTANTLY dtSearch® TERABYTES OF FILE+EMAIL+DB+WEB DATA; reviews/evals
</a>
</li>
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4440431429&iu=/8456/IDG.US_CSMB_PCWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
Manage your network from the palm of your hand with Insight
</a>
</li>
</ul><ul>
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4440011707&iu=/8456/IDG.US_CSMB_PCWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
Your business is growing, your Wifi should too!
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.networkworld.com">
<a href="/"><span class="logo">Network World</span></a>
<span class="tagline"> </span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/networkworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/network-world" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="http://www.facebook.com/#!/pages/Network-World/40168412104" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+networkworld/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/about/rss.html" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li><a href="/category/careers/">Careers</a>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/data-center/">Data Centers</a>
</li>
<li><a href="/category/disaster-recovery/">Disaster Recovery</a>
</li>
<li><a href="/category/home-tech/">Home Tech</a>
</li>
<li><a href="/category/hybrid-cloud/">Hybrid Cloud</a>
</li>
<li class="selected"><a href="/category/internet-of-things/" class="active">Internet of Things</a>
</li>
<li><a href="/category/infrastructure/">Infrastructure Management</a>
</li>
<li><a href="/category/linux/">Linux</a>
</li>
<li><a href="/category/mobile-wireless/">Mobile &amp; Wireless</a>
</li>
<li><a href="/category/lan-wan/">Networking</a>
</li>
<li><a href="/category/software-defined-networking/">SDN</a>
</li>
<li><a href="/category/security/">Security</a>
</li>
<li><a href="/category/small-business/">Small Business</a>
</li>
<li><a href="/category/software/">Software</a>
</li>
<li><a href="/category/storage/">Storage</a>
</li>
<li><a href="/category/uc-voip/">Unified Communications</a>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
<li><a href="/category/wide-area-networking/">WAN</a>
</li>
<li><a href="/category/cisco-subnet/">Cisco Subnet</a>
</li>
<li><a href="/category/microsoft-subnet/">Microsoft Subnet</a>
</li>
<li><a href="/category/tech-primers/">Tech Primers</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
<li><a href="/feature">Features</a></li>
<li><a href="/news">News</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="http://www.ereg.me/IDGEvents" target="_blank" rel="nofollow">Network World Events</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/contactus.html">Contact</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="http://www.idgenterprise.com/reach/networkworld/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/sitemap.html">Site Map</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2017 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="https://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="https://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="https://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js?v=20170927115126"></script>
<script src="/www/js/jquery/jquery-ui.js?v=20170927115126"></script>
<script src="/www/js/jquery/jquery.dfp.min.js?v=20170927115126"></script>
<script src="/www.idge/js/mule/shortstack_nav.js?v=20170927115126"></script>
<script src="/www.idge/js/jquery/jt-scrollable.min.js?v=20170927115126"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js?v=20170927115126"></script>
<script src="/www/js/autocomplete.js?v=20170927115126"></script>
<script src="/www.idge/js/social_sidecar.js?v=20170927115126"></script>
<script src="/www/js/carousel-extend.js?v=20170927115126"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js?v=20170927115126"></script>
<script src="/www.idge/js/article.js?v=20170927115126"></script>
<script src="/www/js/prettify.js?v=20170927115126"></script>
<script src="/www.idge/js/jquery/responsive-tables.js?v=20170927115126"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js?v=20170927115126"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js?v=20170927115126"></script>
<script src="/www.idge/js/global.js?v=20170927115126"></script>
<script src="/www/js/webfonts/ss-social.js?v=20170927115126"></script>
<script src="/www/js/webfonts/ss-standard.js?v=20170927115126"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js?v=20170927115126"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14351;var blueKaiPort=10;var brandCode="nww";var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="https://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[3340,3248]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','2');bk_addPageCtx("purchaseintent","awareness");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickInternetofThings');bk_addPageCtx('event','AmazonClickOpenSource');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js?v=20170927115126"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['']=true;g_arrModules['']=true;g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;g_arrModules['']=true;g_arrModules['']=true;$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Internet of Things",c6:"Article: News",c15:"3229008"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js?v=20170927115126"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"idgnetworkworldprod";s.pageName="NetworkWorld:article:news:Internet of Things:3229008:Canonical's eyes are on IoT";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:networkworld";s.eVar1="D=c1";s.prop2="content type:news";s.eVar2="D=c2";s.prop3="display type:article:news";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="category:internet of things";s.eVar9="D=c9";s.prop11="published:28-Sep-17";s.eVar11="D=c11";s.prop12="aid:3229008";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:jon gold";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3229008/internet-of-things/canonicals-eyes-are-on-iot.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:nww:news:networkworld:article:news:internet of things:3229008:canonical&#039;s eyes are on iot";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="3340";s.eVar53="D=c53";s.prop54="internet of things,open source";s.eVar30="D=c54";s.eVar33=s.prop55="3340,3248";s.eVar33="D=c55";s.prop56="";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop63="awareness";s.prop74="iot";s.eVar58="D=c74";s.prop75="iot";s.eVar60="D=c75";s.prop58="iot:iot";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="28-Sep-17";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://idgenterprise.d1.sc.omtrdc.net/b/ss/idgnetworkworldprod/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="networkworld.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<script type="text/javascript">$thm.logPlEvent({"b":"nww","e":"view","t":"article","id":"3229008"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
</body>
</html>